summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-14 09:08:36 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-14 09:12:24 +0200
commit4ef9854eab9206ea1926e5cccf106b09580e7010 (patch)
tree34d986273bdf504da6ed4234e539b1364074aa1e /dev-cpp/atkmm/atkmm-2.28.0.ebuild
parentx11-terms/gnome-terminal: bump to 3.30.2 (diff)
downloadgentoo-4ef9854eab9206ea1926e5cccf106b09580e7010.tar.gz
gentoo-4ef9854eab9206ea1926e5cccf106b09580e7010.tar.bz2
gentoo-4ef9854eab9206ea1926e5cccf106b09580e7010.zip
dev-cpp/atkmm: bump to 2.28.0, identical to 2.24.3
Gets it out of the way from bump reports and can be stabled as if it were 2.24.3 (in terms of 30 days, etc). Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-cpp/atkmm/atkmm-2.28.0.ebuild')
-rw-r--r--dev-cpp/atkmm/atkmm-2.28.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/atkmm/atkmm-2.28.0.ebuild b/dev-cpp/atkmm/atkmm-2.28.0.ebuild
new file mode 100644
index 000000000000..529b34a36dcf
--- /dev/null
+++ b/dev-cpp/atkmm/atkmm-2.28.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ interface for the ATK library"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.46.2:2[doc?,${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.18.0[${MULTILIB_USEDEP}]
+ >=dev-libs/libsigc++-2.3.2:2[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<dev-cpp/gtkmm-2.22.0
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ $(multilib_native_use_enable doc documentation)
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}