summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-07-26 14:22:31 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-09-06 08:55:18 +0300
commitfbf5279239f798f8170d43c47e16b9d06ce44127 (patch)
tree7afbef6b71356f9e52fe931783d4c6b8c284aaa1 /dev-cpp/benchmark/benchmark-1.5.1.ebuild
parentdev-games/irrlicht: Add patch to remove sys/sysctl.h include (diff)
downloadgentoo-fbf5279239f798f8170d43c47e16b9d06ce44127.tar.gz
gentoo-fbf5279239f798f8170d43c47e16b9d06ce44127.tar.bz2
gentoo-fbf5279239f798f8170d43c47e16b9d06ce44127.zip
dev-cpp/benchmark: New package
Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp/benchmark/benchmark-1.5.1.ebuild')
-rw-r--r--dev-cpp/benchmark/benchmark-1.5.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-cpp/benchmark/benchmark-1.5.1.ebuild b/dev-cpp/benchmark/benchmark-1.5.1.ebuild
new file mode 100644
index 000000000000..c64fe45b19ae
--- /dev/null
+++ b/dev-cpp/benchmark/benchmark-1.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A microbenchmark support library"
+HOMEPAGE="https://github.com/google/benchmark"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBENCHMARK_ENABLE_TESTING=$(usex test)
+ -DBENCHMARK_ENABLE_GTEST_TESTS=OFF
+ -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
+ )
+
+ cmake_src_configure
+}