summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-16 15:53:07 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-16 16:09:05 +0200
commit21169e590d1c0fc770f3a8e102af9d2344009a3a (patch)
tree6c653e88ee9e0fd85dca02efec2ecf9ac8ea9fd5 /dev-cpp/catch
parentdev-cpp/catch: Clean old up (diff)
downloadgentoo-21169e590d1c0fc770f3a8e102af9d2344009a3a.tar.gz
gentoo-21169e590d1c0fc770f3a8e102af9d2344009a3a.tar.bz2
gentoo-21169e590d1c0fc770f3a8e102af9d2344009a3a.zip
dev-cpp/catch: Bump to 1.9.4
Diffstat (limited to 'dev-cpp/catch')
-rw-r--r--dev-cpp/catch/Manifest1
-rw-r--r--dev-cpp/catch/catch-1.9.4.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/catch/Manifest b/dev-cpp/catch/Manifest
index b4b79d1a43a2..465793b340e2 100644
--- a/dev-cpp/catch/Manifest
+++ b/dev-cpp/catch/Manifest
@@ -1 +1,2 @@
DIST Catch-1.9.3.tar.gz 361872 SHA256 67fc8bc96c5ccdd7eb5edf40916fae0a94216c90bfbafdf75bd3843fc5744732 SHA512 55a2af9db182550a6dfa44a1e11e5c6a3a5ff6280f0d5daefd2ae909fac99852030df7d237548696c3e4a4871f61b808fe719ff87d9ff69b88c87349a24241ff WHIRLPOOL 1b9980cedf6f32e14c8d9d6957af2655ca06cd4c256591bc0453269ccb494d54fa888926956206529c88d589c1979764d7e7638d4dc9361ca04ac7fa910256a3
+DIST Catch-1.9.4.tar.gz 363097 SHA256 d67d2ee26ec9f72618dd9b28a9d1b7ba3c6368bc846ecfeda05a1e5d1b8b9b20 SHA512 78d43719e87f5d27132178c5f139b72e6093dd1029eb742bfb48e32b618079e156837fb25d4cbe0fd5044535a5a65ad90510cff8ae93f2695c7bb3fc5cb2a5ec WHIRLPOOL 80b4c36172e62ea12fc4acee096a84cd00b1a290dc2a7a9e9a8e2ff2485e39a619e33f2aee853daa7773d3c877f55788b2d0f86e44542c6f8c0b6027edaf0585
diff --git a/dev-cpp/catch/catch-1.9.4.ebuild b/dev-cpp/catch/catch-1.9.4.ebuild
new file mode 100644
index 000000000000..dd8e74f2615d
--- /dev/null
+++ b/dev-cpp/catch/catch-1.9.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/philsquared/Catch"
+SRC_URI="https://github.com/philsquared/Catch/archive/v${PV}.tar.gz -> ${P^}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P^}
+
+# CMake is only used to build & run tests, so override phases
+src_configure() { :; }
+src_compile() { :; }
+
+src_test() {
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test
+}
+
+src_install() {
+ # same location as used in fedora
+ insinto /usr/include/catch
+ doins -r include/.
+ dodoc -r docs/.
+}