summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-02-26 15:31:07 +0100
committerDavid Seifert <soap@gentoo.org>2022-02-26 15:31:07 +0100
commit51d418d15538531b3c3d5c5ab48fd9bb1731ee9f (patch)
treee4bdcb236bec0a0537211380620b168d2b863681 /dev-cpp/catch
parentdev-cpp/catch: drop 2.13.7 (diff)
downloadgentoo-51d418d15538531b3c3d5c5ab48fd9bb1731ee9f.tar.gz
gentoo-51d418d15538531b3c3d5c5ab48fd9bb1731ee9f.tar.bz2
gentoo-51d418d15538531b3c3d5c5ab48fd9bb1731ee9f.zip
dev-cpp/catch: add patch for brittle output test
Closes: https://bugs.gentoo.org/834066 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/catch')
-rw-r--r--dev-cpp/catch/catch-2.13.8.ebuild2
-rw-r--r--dev-cpp/catch/files/catch-2.13.8-musl-tests.patch24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-cpp/catch/catch-2.13.8.ebuild b/dev-cpp/catch/catch-2.13.8.ebuild
index a57a9d4e9d0f..9711bc919ca8 100644
--- a/dev-cpp/catch/catch-2.13.8.ebuild
+++ b/dev-cpp/catch/catch-2.13.8.ebuild
@@ -28,6 +28,8 @@ RESTRICT="!test? ( test )"
BDEPEND="test? ( ${PYTHON_DEPS} )"
+PATCHES=( "${FILESDIR}"/${P}-musl-tests.patch )
+
pkg_setup() {
use test && python-any-r1_pkg_setup
}
diff --git a/dev-cpp/catch/files/catch-2.13.8-musl-tests.patch b/dev-cpp/catch/files/catch-2.13.8-musl-tests.patch
new file mode 100644
index 000000000000..86c60c15f34d
--- /dev/null
+++ b/dev-cpp/catch/files/catch-2.13.8-musl-tests.patch
@@ -0,0 +1,24 @@
+From 3e88ccff3ba573fb6d1ab746596411eebe310a6b Mon Sep 17 00:00:00 2001
+From: John Zimmermann <me@johnnynator.dev>
+Date: Thu, 31 Dec 2020 16:24:16 +0100
+Subject: [PATCH] Do not match exact amount of spaces for errno macro expansion
+ in approvalTests.py
+
+E.g. musl libc expands errno() to __errno_location() without a space between, glibc has 1 space.
+---
+ scripts/approvalTests.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/scripts/approvalTests.py b/scripts/approvalTests.py
+index f8b9425c7c..73e9b83239 100755
+--- a/scripts/approvalTests.py
++++ b/scripts/approvalTests.py
+@@ -44,7 +44,7 @@
+
+ # errno macro expands into various names depending on platform, so we need to fix them up as well
+ errnoParser = re.compile(r'''
+- \(\*__errno_location\ \(\)\)
++ \(\*__errno_location\s*\(\)\)
+ |
+ \(\*__error\(\)\)
+ |