summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-08-25 23:24:23 +0200
committerDavid Seifert <soap@gentoo.org>2018-08-25 23:24:23 +0200
commit9edabe5400b81e731dcadefaaf2e8ba6e5f36a9b (patch)
tree359c10dcd689c18d0c15a1fcf07b1d41cf7491c6 /dev-cpp/catch
parentapp-i18n/scim: Remove dep on removed qt4 (diff)
downloadgentoo-9edabe5400b81e731dcadefaaf2e8ba6e5f36a9b.tar.gz
gentoo-9edabe5400b81e731dcadefaaf2e8ba6e5f36a9b.tar.bz2
gentoo-9edabe5400b81e731dcadefaaf2e8ba6e5f36a9b.zip
dev-cpp/catch: Version bump to 2.3.0
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-cpp/catch')
-rw-r--r--dev-cpp/catch/Manifest1
-rw-r--r--dev-cpp/catch/catch-2.3.0.ebuild48
-rw-r--r--dev-cpp/catch/files/catch-2.3.0-python-automagic.patch25
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-cpp/catch/Manifest b/dev-cpp/catch/Manifest
index dcfd1f2c0ee7..dc01d5f3e0e7 100644
--- a/dev-cpp/catch/Manifest
+++ b/dev-cpp/catch/Manifest
@@ -1,2 +1,3 @@
DIST Catch-1.11.0.tar.gz 376132 BLAKE2B 23a1a6292dd91ec1c71923b4902b42b59ff6be5227b666f68ef0dc33756a58a63edd70a9b139dda0b1860c2b7a0cfec7ab9262e6447eff3184cfe28ea9b0aa77 SHA512 33085c2671f78c7562eace909564b2730eabcaf4490cd463402e66ab4ac2be1fe4fe360916c11aa589ba4a010622444126ee2ae747783b5869b5d7276361f132
DIST Catch2-2.2.2.tar.gz 497244 BLAKE2B d5073d56b9399bd7f50bafc7758e60e31ba4434e229f92ca92cd04257f4a54cec925ad3180cc964c4f69edbaa7fc14f8af8e828421e2bb2b4f6c59eaea5cc06d SHA512 ab91036c6c3ace087d0382ce99f26b2c30a4b75d52f285619ca282a618470fe388afe47495f3b2764268d600c6834c60ba464483d06f3a1c4316c099477c8e38
+DIST Catch2-2.3.0.tar.gz 506374 BLAKE2B f692eb0933ca578edf0f15cb83139d2fab03390b3980a686ea495101165d612c848b642ad1e7233bce5bb164c80958c9cbfbc229e72a1ae6947aa4dffdf27556 SHA512 e9a089b504c339e87bda0fb1a4040d9d19c932a4bc7dca41bdad6edfcf8c428f4152ff1e0c898dfdf6b20bd5d901c343bed00ad89351fa5182f3c106e0fb4b03
diff --git a/dev-cpp/catch/catch-2.3.0.ebuild b/dev-cpp/catch/catch-2.3.0.ebuild
new file mode 100644
index 000000000000..94a870ee7cea
--- /dev/null
+++ b/dev-cpp/catch/catch-2.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+inherit cmake-utils python-any-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
+else
+ MY_P=${PN^}2-${PV}
+ SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+
+ S=${WORKDIR}/${MY_P}
+fi
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.0-python-automagic.patch
+)
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCATCH_ENABLE_WERROR=OFF
+ -DBUILD_TESTING=$(usex test)
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/catch/files/catch-2.3.0-python-automagic.patch b/dev-cpp/catch/files/catch-2.3.0-python-automagic.patch
new file mode 100644
index 000000000000..c7fa4c6d22f6
--- /dev/null
+++ b/dev-cpp/catch/files/catch-2.3.0-python-automagic.patch
@@ -0,0 +1,25 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -36,7 +36,11 @@
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /ENTRY:wmainCRTStartup")
+ endif()
+
++find_package(PythonInterp)
+ if (BUILD_TESTING AND CATCH_BUILD_TESTING AND NOT_SUBPROJECT)
++ if (NOT PYTHONINTERP_FOUND)
++ message(FATAL_ERROR "Python not found, but required for tests")
++ endif()
+ add_subdirectory(projects)
+ endif()
+
+--- a/projects/CMakeLists.txt
++++ b/projects/CMakeLists.txt
+@@ -317,7 +317,7 @@
+ set_tests_properties(NoTest PROPERTIES PASS_REGULAR_EXPRESSION "No test cases matched")
+
+ # AppVeyor has a Python 2.7 in path, but doesn't have .py files as autorunnable
+-add_test(NAME ApprovalTests COMMAND python ${CATCH_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
++add_test(NAME ApprovalTests COMMAND ${PYTHON_EXECUTABLE} ${CATCH_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
+ set_tests_properties(ApprovalTests PROPERTIES FAIL_REGULAR_EXPRESSION "Results differed")
+
+ if (CATCH_USE_VALGRIND)