summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2021-09-01 11:46:26 +0200
committerSam James <sam@gentoo.org>2021-09-07 21:23:46 +0100
commitdafe205df773f3ed6f0867733f571a6f6d2efde9 (patch)
tree5f3677c3dd055cd47b82fa4d7773423d3dda30be /dev-cpp/doctest
parentdev-perl/WWW-Mechanize: add 2.40.0 (diff)
downloadgentoo-dafe205df773f3ed6f0867733f571a6f6d2efde9.tar.gz
gentoo-dafe205df773f3ed6f0867733f571a6f6d2efde9.tar.bz2
gentoo-dafe205df773f3ed6f0867733f571a6f6d2efde9.zip
dev-cpp/doctest: initial import
Bug: https://bugs.gentoo.org/811318 Bug: https://bugs.gentoo.org/809752 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/doctest')
-rw-r--r--dev-cpp/doctest/Manifest1
-rw-r--r--dev-cpp/doctest/doctest-2.4.6.ebuild23
-rw-r--r--dev-cpp/doctest/metadata.xml15
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/doctest/Manifest b/dev-cpp/doctest/Manifest
new file mode 100644
index 000000000000..21c9d2b12467
--- /dev/null
+++ b/dev-cpp/doctest/Manifest
@@ -0,0 +1 @@
+DIST doctest-2.4.6.tar.gz 2277281 BLAKE2B e6835ad33522273a3151ccfa1e760a150e2f0ccc15fb739cb518d8c9b4258f4b1529537bb6f41b285660aa00f1791b30a7db14155d9f23ea54dd11bfdeb81ec3 SHA512 a5cccf085af946003140af688f071a6407d42fc685324a537e3b704ef9de0f2228bd06eabfd1df8da70dec001420dd0b2813e5e4320b5c1da450cb0aadd63788
diff --git a/dev-cpp/doctest/doctest-2.4.6.ebuild b/dev-cpp/doctest/doctest-2.4.6.ebuild
new file mode 100644
index 000000000000..09d25151de7d
--- /dev/null
+++ b/dev-cpp/doctest/doctest-2.4.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="The fastest feature-rich C++11/14/17/20 single-header testing framework"
+HOMEPAGE="https://github.com/onqtam/doctest"
+SRC_URI="https://github.com/onqtam/doctest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOCTEST_WITH_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/dev-cpp/doctest/metadata.xml b/dev-cpp/doctest/metadata.xml
new file mode 100644
index 000000000000..8c1c2bc2442c
--- /dev/null
+++ b/dev-cpp/doctest/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>arkamar@atlas.cz</email>
+ <name>Petr Vaněk</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">onqtam/doctest</remote-id>
+ </upstream>
+</pkgmetadata>