summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-18 01:23:19 +0100
committerSam James <sam@gentoo.org>2022-09-18 01:23:19 +0100
commit9fb1c86112a743885d91530ba44f394a821b9ba1 (patch)
tree2bd821e9cebd4a6465ae6d24024bac4650c2c58d /dev-cpp/folly
parentsys-devel/gcc: unkeyword 11.3.1_p20220916 (diff)
downloadgentoo-9fb1c86112a743885d91530ba44f394a821b9ba1.tar.gz
gentoo-9fb1c86112a743885d91530ba44f394a821b9ba1.tar.bz2
gentoo-9fb1c86112a743885d91530ba44f394a821b9ba1.zip
dev-cpp/folly: add 2022.09.12.00
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/folly')
-rw-r--r--dev-cpp/folly/Manifest1
-rw-r--r--dev-cpp/folly/folly-2022.09.12.00.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-cpp/folly/Manifest b/dev-cpp/folly/Manifest
index cee34716d5ed..c485a2f9a8cd 100644
--- a/dev-cpp/folly/Manifest
+++ b/dev-cpp/folly/Manifest
@@ -6,3 +6,4 @@ DIST folly-v2022.08.15.00.tar.gz 3691439 BLAKE2B 96ba34a18b51ea91aacd2bbcdbfef85
DIST folly-v2022.08.22.00.tar.gz 3693126 BLAKE2B 1d28c114068d6d37bb0d57fddc9ab22438efc967aba810ba463b2e63c451a7d66152c5ec5b42d10879ed3d44467af5548d98998c52080b10f82aabfaec5f8b85 SHA512 b042a25c4e114d7098dbba94699a472e94a9074fe0814b1c5417e5bf995b69a22704613ae2a863d4e098511b0b8cc38c2e7c172a02b7bf772e238edcfe967c9e
DIST folly-v2022.08.29.00.tar.gz 3696645 BLAKE2B c1ff618be8b6a73bf0a1249212cf904ac472711086e54da73dd631ecf002761e30496e8631d6591f51e279b736ae9b3fe50959de6b1f86f01f9d6bc08fe675fc SHA512 1437a1314e26624715a0bb781049e19300eb3a67648287b319c55ce0dfbc867a09bd9d2f0cece6fc75fc62b21899aa94b464ae49c12687be7c94fdf0c7b95790
DIST folly-v2022.09.05.00.tar.gz 3707503 BLAKE2B 417df2b8e5dc21b6bffa815b265f85321c93c5d841ca0be77da46c32d6c75dc135a86ec37d8d6a6c3e2b95d8ccfe73e30739713c97e43f4cd3ba18c8a9d3dbde SHA512 5ab206606c3e8b0930e098bc86406edd1b66e99bfa5b3bdcd93bfc054c83fae5271b4257a03a2e18d9f1f789bf64088de2e0c3bbd0a9618ef4281e748da0ccba
+DIST folly-v2022.09.12.00.tar.gz 3710760 BLAKE2B af59580ebee3229a6564c4b29e1d24bc405f4ae3b79751af315245c87472293f97c2d78348c92620d3196d1d41a7b55af9627cd42d23f74cbf6f00d129b3b77c SHA512 f9d0ca44f6f0c343d16e8ee5408808830b30155d42a257c48e627f9a82bb4a57568a7feeba01cf73704db68af1eee7424971540635d5dfe1728fc2ae73953940
diff --git a/dev-cpp/folly/folly-2022.09.12.00.ebuild b/dev-cpp/folly/folly-2022.09.12.00.ebuild
new file mode 100644
index 000000000000..fcc47d18f6a8
--- /dev/null
+++ b/dev-cpp/folly/folly-2022.09.12.00.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# These must be bumped together:
+# dev-cpp/edencommon
+# dev-cpp/folly
+# dev-util/watchman
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="An open-source C++ library developed and used at Facebook"
+HOMEPAGE="https://github.com/facebook/folly"
+SRC_URI="https://github.com/facebook/folly/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="llvm-libunwind test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-arch/bzip2
+ app-arch/lz4:=
+ app-arch/snappy:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ dev-cpp/gflags:=
+ dev-cpp/glog:=[gflags]
+ dev-libs/boost:=[context]
+ dev-libs/double-conversion:=
+ dev-libs/libaio
+ dev-libs/libevent:=
+ dev-libs/libfmt:=
+ dev-libs/libsodium:=
+ dev-libs/openssl:=
+ >=sys-libs/liburing-2.2:=
+ sys-libs/zlib
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ !llvm-libunwind? ( sys-libs/libunwind:= )"
+# libiberty is linked statically
+DEPEND="${RDEPEND}
+ sys-libs/binutils-libs
+ test? ( dev-cpp/gtest )"
+BDEPEND="test? ( sys-devel/clang )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2022.07.04.00-musl-fix.patch
+)
+
+pkg_setup() {
+ [[ ${BUILD_TYPE} == binary ]] && return
+
+ if use test && ! tc-is-clang ; then
+ # Always build w/ Clang for now to avoid gcc ICE
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=106230
+ #if [[ $(gcc-major-version) -eq 12 ]] ; then
+ # return
+ #fi
+
+ ## Only older GCC 11 is broken
+ #if [[ $(gcc-major-version) -eq 11 && $(gcc-minor-version) -ge 3 && $(gcc-micro-version) -ge 1 ]] ; then
+ # return
+ #fi
+
+ ewarn "Forcing build with Clang due to GCC bug (because tests are enabled)"
+ #ewarn "(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104008)"
+
+ export CC=${CHOST}-clang
+ export CXX=${CHOST}-clang++
+ fi
+}
+
+src_configure() {
+ # Fragile when changing compilers
+ export CCACHE_DISABLE=1
+
+ # TODO: liburing could in theory be optional but fails to link
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # - timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest
+ # Long-standing known test failure
+ # TODO: report upstream
+ # - HHWheelTimerTest.HHWheelTimerTest.CancelTimeout
+ # Timeouts are fragile
+ -E "(timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest.HHWheelTimerTest.CancelTimeout)"
+ )
+
+ cmake_src_test
+}