summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <dm0@redhat.com>2019-03-11 20:13:09 -0400
committerMichał Górny <mgorny@gentoo.org>2019-07-06 08:11:23 +0200
commit932dc78d1c7fff951f55c2ca509634e9d9e304cb (patch)
tree26dcaaddf93004ae53710bbd9d133e867db50ae0 /dev-cpp/gflags/gflags-9999.ebuild
parentsys-kernel/pf-sources: Update to 5.1_p7 (diff)
downloadgentoo-932dc78d1c7fff951f55c2ca509634e9d9e304cb.tar.gz
gentoo-932dc78d1c7fff951f55c2ca509634e9d9e304cb.tar.bz2
gentoo-932dc78d1c7fff951f55c2ca509634e9d9e304cb.zip
dev-cpp/gflags: EAPI=7
This allows the cmake eclass to use BDEPEND, so the host cmake can be used without having to cross-compile it. Signed-off-by: David Michael <dm0@redhat.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-cpp/gflags/gflags-9999.ebuild')
-rw-r--r--dev-cpp/gflags/gflags-9999.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-cpp/gflags/gflags-9999.ebuild b/dev-cpp/gflags/gflags-9999.ebuild
index 91f405e1e9bf..95cd79c7ef3d 100644
--- a/dev-cpp/gflags/gflags-9999.ebuild
+++ b/dev-cpp/gflags/gflags-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
inherit cmake-multilib
@@ -25,7 +25,6 @@ DOCS=( ChangeLog.txt README.md )
multilib_src_configure() {
local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
-DBUILD_STATIC_LIBS=$(usex static-libs)
-DBUILD_TESTING=$(usex test)
# avoid installing .cmake/packages, e.g.: