summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-04-08 11:21:30 +0300
committerMart Raudsepp <leio@gentoo.org>2019-04-08 11:21:30 +0300
commit06b2dea63e1ad950fd60714ddffa6874e9d9cd87 (patch)
tree674cb53f76afb36430d54b62670ddb54e8910b7e /dev-cpp/glibmm/glibmm-2.56.0.ebuild
parentmedia-libs/tiff: arm64 stable (bug #669948) (diff)
downloadgentoo-06b2dea63e1ad950fd60714ddffa6874e9d9cd87.tar.gz
gentoo-06b2dea63e1ad950fd60714ddffa6874e9d9cd87.tar.bz2
gentoo-06b2dea63e1ad950fd60714ddffa6874e9d9cd87.zip
dev-cpp/glibmm: remove old
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-cpp/glibmm/glibmm-2.56.0.ebuild')
-rw-r--r--dev-cpp/glibmm/glibmm-2.56.0.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-cpp/glibmm/glibmm-2.56.0.ebuild b/dev-cpp/glibmm/glibmm-2.56.0.ebuild
deleted file mode 100644
index 20a072129508..000000000000
--- a/dev-cpp/glibmm/glibmm-2.56.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnome2 multilib-minimal
-
-DESCRIPTION="C++ interface for glib2"
-HOMEPAGE="https://www.gtkmm.org"
-
-LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
-SLOT="2"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="doc debug test"
-
-RDEPEND="
- >=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
- >=dev-libs/glib-2.55.1:2[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-# dev-cpp/mm-common needed for eautoreconf
-
-src_prepare() {
- if ! use test; then
- # don't waste time building tests
- sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
- -i Makefile.am Makefile.in || die "sed 1 failed"
- fi
-
- # don't build examples - we want to install example sources, not binaries
- sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
- -i Makefile.am Makefile.in || die "sed 2 failed"
-
- gnome2_src_prepare
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" gnome2_src_configure \
- $(use_enable debug debug-refcounting) \
- $(multilib_native_use_enable doc documentation) \
- --enable-deprecated-api
-}
-
-multilib_src_test() {
- cd tests
- default
-
- for i in */test; do
- ${i} || die "Running tests failed at ${i}"
- done
-}
-
-multilib_src_install() {
- gnome2_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
- find examples -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
- dodoc -r examples
-}