summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-17 18:42:01 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-17 22:47:09 -0500
commit1e0a70d9a8899bcbfb39fec1e1d0b89ae67e19b9 (patch)
tree06fbd2a891745ebd917aae132970c103e949e23c /dev-cpp/glibmm
parentdev-cpp/pangomm: Version bump to 2.50.0 (diff)
downloadgentoo-1e0a70d9a8899bcbfb39fec1e1d0b89ae67e19b9.tar.gz
gentoo-1e0a70d9a8899bcbfb39fec1e1d0b89ae67e19b9.tar.bz2
gentoo-1e0a70d9a8899bcbfb39fec1e1d0b89ae67e19b9.zip
dev-cpp/glibmm: Version bump to 2.70.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/glibmm')
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/glibmm-2.70.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index e3240765a51f..6cd3f3284f99 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -2,3 +2,4 @@ DIST glibmm-2.66.1.tar.xz 7509820 BLAKE2B 4750940093cadbae7c32d387ac8b16c8230eb0
DIST glibmm-2.66.2.tar.xz 7603104 BLAKE2B 5696391bd5dbb35f8c961250af6d9b2644e900ac6a800054e9e7630cbf4882c17ef1bf8cf322e89a3bdbe613d13d4a045920bfc1071442daa3afc78afa8cd759 SHA512 097af6b140a5af3e52cc2c5d251475a5aa923d0c528c3cbc97f31d3a95868bcb3aa2328047ca94a55ef7fd188f271917dfe29faa86f477a441f0a024284216f9
DIST glibmm-2.68.1.tar.xz 7657712 BLAKE2B a8141e53f89c981a9916d5f71dfd8c6d08e45a653b98c507acaadfefbedf2f22e8130a722f3398f5e0dff8196ffc8efa6567ebb2c8290f7373e34377e281db18 SHA512 ca164f986da651e66bb5b98a760853e73d57ff84e035809d4c3b2c0a1b6ddf8ca68ffc49a71d0e0b2e14eca1c00e2e727e3bf3821e0b2b3a808397c3d33c6d5c
DIST glibmm-2.68.2.tar.xz 7844508 BLAKE2B 890f3a8f15580891df000acfe365989a6b09a63712b5f24f999a70e62983c725c9aef2b386b8995933c41b345164bb0b330b6cb0af182476f14657db8ba7d0cf SHA512 96b2970ac47e6a8de2d4352412f0107fbdcb61942d27f20a2f533f9704304e5f55c52829567457e7c925f830a69c739bf00676882741ed2969e52caf3e135c46
+DIST glibmm-2.70.0.tar.xz 7874312 BLAKE2B 5d0fb24444b8764e3f972f342a540164debb841f74e5d27db721feff9baa70c9ff5821b26642cb8c5da048f9a1271b1ed7283d9f0338ba0f184be396981310e3 SHA512 059cab7f0b865303cef3cba6c4f3a29ae4e359aba428f5e79cea6fedd3f1e082199f673323cf804902cee14b91739598fbc6ff706ec36f19c4d793d032782518
diff --git a/dev-cpp/glibmm/glibmm-2.70.0.ebuild b/dev-cpp/glibmm/glibmm-2.70.0.ebuild
new file mode 100644
index 000000000000..8cf7ffdce6e5
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.70.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.68"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.69.1:2[${MULTILIB_USEDEP}]
+ dev-libs/libsigc++:3[doc?,${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+"
+
+src_prepare() {
+ default
+
+ # giomm_tls_client requires FEATURES=-network-sandbox and glib-networking rdep
+ sed -i -e '/giomm_tls_client/d' tests/meson.build || die
+
+ if ! use test; then
+ sed -i -e "/^subdir('tests')/d" meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dwarnings=min
+ -Dbuild-deprecated-api=true
+ $(meson_native_use_bool doc build-documentation)
+ $(meson_use debug debug-refcounting)
+ -Dbuild-examples=false
+ )
+ meson_src_configure
+}