summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-11-11 13:20:37 +0100
committerPacho Ramos <pacho@gentoo.org>2021-11-11 13:59:09 +0100
commitaef60f3c8883751764887cff6eb02119cee2b81e (patch)
treebde65031287d133009ff7c43941a5b3fdbf6703b /dev-cpp/glibmm
parentdev-cpp/glibmm: Bump to 2.66.2 (diff)
downloadgentoo-aef60f3c8883751764887cff6eb02119cee2b81e.tar.gz
gentoo-aef60f3c8883751764887cff6eb02119cee2b81e.tar.bz2
gentoo-aef60f3c8883751764887cff6eb02119cee2b81e.zip
dev-cpp/glibmm: Bump to 2.68.2
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-cpp/glibmm')
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/glibmm-2.68.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index fa95af5ab04f..e3240765a51f 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -1,3 +1,4 @@
DIST glibmm-2.66.1.tar.xz 7509820 BLAKE2B 4750940093cadbae7c32d387ac8b16c8230eb08ed1645e457edfa27542a2e8a01d70de08bb41d1872dd1f03d1506bfaefc2af582250ca64ad480ce5f98f20d56 SHA512 caf57c2c9d163fff45041c33ed70d2692040d7bea44660d68e8c16a76be2609e0f857a5e16ad5220a0ec681a560c864dc86c2988a2c40741b4f29c9fe5b7d8b9
DIST glibmm-2.66.2.tar.xz 7603104 BLAKE2B 5696391bd5dbb35f8c961250af6d9b2644e900ac6a800054e9e7630cbf4882c17ef1bf8cf322e89a3bdbe613d13d4a045920bfc1071442daa3afc78afa8cd759 SHA512 097af6b140a5af3e52cc2c5d251475a5aa923d0c528c3cbc97f31d3a95868bcb3aa2328047ca94a55ef7fd188f271917dfe29faa86f477a441f0a024284216f9
DIST glibmm-2.68.1.tar.xz 7657712 BLAKE2B a8141e53f89c981a9916d5f71dfd8c6d08e45a653b98c507acaadfefbedf2f22e8130a722f3398f5e0dff8196ffc8efa6567ebb2c8290f7373e34377e281db18 SHA512 ca164f986da651e66bb5b98a760853e73d57ff84e035809d4c3b2c0a1b6ddf8ca68ffc49a71d0e0b2e14eca1c00e2e727e3bf3821e0b2b3a808397c3d33c6d5c
+DIST glibmm-2.68.2.tar.xz 7844508 BLAKE2B 890f3a8f15580891df000acfe365989a6b09a63712b5f24f999a70e62983c725c9aef2b386b8995933c41b345164bb0b330b6cb0af182476f14657db8ba7d0cf SHA512 96b2970ac47e6a8de2d4352412f0107fbdcb61942d27f20a2f533f9704304e5f55c52829567457e7c925f830a69c739bf00676882741ed2969e52caf3e135c46
diff --git a/dev-cpp/glibmm/glibmm-2.68.2.ebuild b/dev-cpp/glibmm/glibmm-2.68.2.ebuild
new file mode 100644
index 000000000000..b380e4af013d
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.68.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.68"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.63.0:2[${MULTILIB_USEDEP}]
+ dev-libs/libsigc++:3[doc?,${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+"
+
+src_prepare() {
+ default
+
+ # giomm_tls_client requires FEATURES=-network-sandbox and glib-networking rdep
+ sed -i -e '/giomm_tls_client/d' tests/meson.build || die
+
+ if ! use test; then
+ sed -i -e "/^subdir('tests')/d" meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dwarnings=min
+ -Dbuild-deprecated-api=true
+ $(meson_native_use_bool doc build-documentation)
+ $(meson_use debug debug-refcounting)
+ -Dbuild-examples=false
+ )
+ meson_src_configure
+}