summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-22 23:24:08 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-23 23:42:58 -0400
commitca56aa38dfe216739149f2bce498089eb50abd14 (patch)
tree75f9486cee1f8f8c655a45d80dbb7a87bc8049fa /dev-cpp/glibmm
parentdev-cpp/glibmm: Rename IUSE=doc → IUSE=gtk-doc (diff)
downloadgentoo-ca56aa38dfe216739149f2bce498089eb50abd14.tar.gz
gentoo-ca56aa38dfe216739149f2bce498089eb50abd14.tar.bz2
gentoo-ca56aa38dfe216739149f2bce498089eb50abd14.zip
dev-cpp/glibmm: Version bump to 2.66.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/glibmm')
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/glibmm-2.66.5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index c11867d0d51a..242bd627bf5f 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -1,2 +1,3 @@
DIST glibmm-2.66.4.tar.xz 7606108 BLAKE2B 5ff069110701d315c5d639e5efd824eb136b73fa29dc6e3fe5aead675e87b335bb2cbbbad2d9187285ce7086014aa316c07b672d88c5ba5fdaa3b8888e13af0a SHA512 9b1e0c09a11182384313ea4a7ba484ebab894528e08169a610387f207b5a7f8db9338466cd3e9eb3fa55e1c12817351ea27c39d6503208af67ba619f9d249c75
+DIST glibmm-2.66.5.tar.xz 7610516 BLAKE2B 766939ad6a5cd94bc642da7e9801ccb4f693d652ad4afcfc15b6e12a646b0d5d9c203a04328d13727f4e6c35730e7e9cc431f448618c75df305874dacaf0d7aa SHA512 3c1f91a1d91c23c5975254f5bf499f6752b6e3f1b056511133722cdfc853ffd2a94c375c0441dbb3f0933e7a257449ca4e365355ed580bd72d88c08d99a76684
DIST glibmm-2.72.1.tar.xz 7921260 BLAKE2B 4078c2a6a12257a84844d3fa70c8b6a1a28b7c184f7bfbbf2adc882806099f7211378d6f7a23b1bbd18514ced9ada56642eb4ff877ee23cd70b4ee6b1a270510 SHA512 aa52c7b73e8f3437c2da9e8da74f84b9f07c7aa40a5fa232a7418b4af19575cbde01f6cbe9fb3fc3227bd9281a9439156a51d10a0c2c1a1beca226c7c93fe660
diff --git a/dev-cpp/glibmm/glibmm-2.66.5.ebuild b/dev-cpp/glibmm/glibmm-2.66.5.ebuild
new file mode 100644
index 000000000000..f730efed4596
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.66.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="https://www.gtkmm.org https://gitlab.gnome.org/GNOME/glibmm"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="gtk-doc debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.61.2:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ gtk-doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-perl/XML-Parser
+ dev-libs/libxslt
+ media-gfx/graphviz
+ )
+"
+
+src_prepare() {
+ default
+
+ # giomm_tls_client requires FEATURES=-network-sandbox and glib-networking rdep
+ sed -i -e '/giomm_tls_client/d' tests/meson.build || die
+
+ if ! use test; then
+ sed -i -e "/^subdir('tests')/d" meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dwarnings=min
+ -Dbuild-deprecated-api=true
+ $(meson_native_use_bool gtk-doc build-documentation)
+ $(meson_use debug debug-refcounting)
+ -Dbuild-examples=false
+ )
+ meson_src_configure
+}