summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-08 14:22:38 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-08 14:26:39 -0700
commitcb9c80ddf7a518414e38fbf6cb47ef8d1fc635b1 (patch)
treeba6e2a1bfd47351ea7d84691a6b4b7d376046caa /dev-cpp/glibmm
parentdev-python/jupyter_packaging: Add explicit rdep on setuptools (diff)
downloadgentoo-cb9c80ddf7a518414e38fbf6cb47ef8d1fc635b1.tar.gz
gentoo-cb9c80ddf7a518414e38fbf6cb47ef8d1fc635b1.tar.bz2
gentoo-cb9c80ddf7a518414e38fbf6cb47ef8d1fc635b1.zip
dev-cpp/glibmm: Version bump to 2.72.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/glibmm')
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/glibmm-2.72.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index b4c6953ae0f1..c588d97ebe60 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -1,2 +1,3 @@
DIST glibmm-2.66.2.tar.xz 7603104 BLAKE2B 5696391bd5dbb35f8c961250af6d9b2644e900ac6a800054e9e7630cbf4882c17ef1bf8cf322e89a3bdbe613d13d4a045920bfc1071442daa3afc78afa8cd759 SHA512 097af6b140a5af3e52cc2c5d251475a5aa923d0c528c3cbc97f31d3a95868bcb3aa2328047ca94a55ef7fd188f271917dfe29faa86f477a441f0a024284216f9
DIST glibmm-2.70.0.tar.xz 7874312 BLAKE2B 5d0fb24444b8764e3f972f342a540164debb841f74e5d27db721feff9baa70c9ff5821b26642cb8c5da048f9a1271b1ed7283d9f0338ba0f184be396981310e3 SHA512 059cab7f0b865303cef3cba6c4f3a29ae4e359aba428f5e79cea6fedd3f1e082199f673323cf804902cee14b91739598fbc6ff706ec36f19c4d793d032782518
+DIST glibmm-2.72.0.tar.xz 7921092 BLAKE2B 5f4fc6df527c6aa99886d5afe3233e15a37319b1c9f7814c9edfb574abb9b0f1b04b887d2a275c113382b0b301df7d3a22fc4398bc61746bd353e73015ec8770 SHA512 73b8a7a3848e6c5c9b532547002e44dd77ffc1ff80a849772cf48ad5aa14965bd6d50e01b2597320a578c3655bc1ef42804c0f2fed3ac632fe0218f8ae4788ff
diff --git a/dev-cpp/glibmm/glibmm-2.72.0.ebuild b/dev-cpp/glibmm/glibmm-2.72.0.ebuild
new file mode 100644
index 000000000000..ec1190baa58d
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.72.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.68"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.71.2:2[${MULTILIB_USEDEP}]
+ dev-libs/libsigc++:3[doc?,${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+"
+
+src_prepare() {
+ default
+
+ # giomm_tls_client requires FEATURES=-network-sandbox and glib-networking rdep
+ sed -i -e '/giomm_tls_client/d' tests/meson.build || die
+
+ if ! use test; then
+ sed -i -e "/^subdir('tests')/d" meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dwarnings=min
+ -Dbuild-deprecated-api=true
+ $(meson_native_use_bool doc build-documentation)
+ $(meson_use debug debug-refcounting)
+ -Dbuild-examples=false
+ )
+ meson_src_configure
+}