summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-17 23:15:38 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-17 23:16:28 -0400
commit475dab847fb2e961d0ef35173cd1295d17bf966b (patch)
tree01059f6997b89a2176b9069f7f442640fb60d4b0 /dev-cpp/glog/glog-0.4.0.ebuild
parentsys-libs/libunwind: fix docs override (diff)
downloadgentoo-475dab847fb2e961d0ef35173cd1295d17bf966b.tar.gz
gentoo-475dab847fb2e961d0ef35173cd1295d17bf966b.tar.bz2
gentoo-475dab847fb2e961d0ef35173cd1295d17bf966b.zip
Revert "dev-cpp/glog: Drop old versions"
Still needed by sci-libs/caffe2. This reverts commit 3817d0904d1cd868a656cf05c50f431bd6a6ccb7. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/glog/glog-0.4.0.ebuild')
-rw-r--r--dev-cpp/glog/glog-0.4.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-cpp/glog/glog-0.4.0.ebuild b/dev-cpp/glog/glog-0.4.0.ebuild
new file mode 100644
index 000000000000..9b10f2e2fc95
--- /dev/null
+++ b/dev-cpp/glog/glog-0.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Google's C++ logging library"
+HOMEPAGE="https://github.com/google/glog"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+# -sparc as libunwind is not ported on sparc
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 -sparc x86 ~amd64-linux ~x86-linux"
+IUSE="gflags static-libs test"
+RESTRICT="test"
+
+RDEPEND="sys-libs/libunwind[${MULTILIB_USEDEP}]
+ gflags? ( dev-cpp/gflags[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.0-fix-x32-build.patch
+ "${FILESDIR}"/${PN}-0.4.0-errnos.patch
+ "${FILESDIR}"/${PN}-0.4.0-fix-test-on-ports.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ ac_cv_lib_gflags_main="$(usex gflags)"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}