summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2019-06-08 18:27:02 -0400
committerMichał Górny <mgorny@gentoo.org>2019-06-15 22:29:28 +0200
commite58c0ab35c35b4de684f86137e432efba6592080 (patch)
treeec1b0c76883af5a9e6c4f451a9120e2915aafc58 /dev-cpp/gtest
parentdev-cpp/gtest: Update patch for gtest-9999 (diff)
downloadgentoo-e58c0ab35c35b4de684f86137e432efba6592080.tar.gz
gentoo-e58c0ab35c35b4de684f86137e432efba6592080.tar.bz2
gentoo-e58c0ab35c35b4de684f86137e432efba6592080.zip
dev-cpp/gtest: Update to 1.9.0_pre20190607
Latest dev-libs/protobuf-3.8.0 is going to need the INSTANTIATE_TEST_SUITE_P macro which is defined in upstream master branch. Also, fixes for building with gcc-9 have been included upstream so this kills two bugs. Reported-by: Toralf Förster <toralf@gentoo.org> Closes: https://bugs.gentoo.org/687086 Reported-by: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com> Tested-by: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com> Closes: https://bugs.gentoo.org/687606 Closes: https://github.com/gentoo/gentoo/pull/12222 Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-cpp/gtest')
-rw-r--r--dev-cpp/gtest/Manifest1
-rw-r--r--dev-cpp/gtest/gtest-1.9.0_pre20190607.ebuild79
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild9
3 files changed, 87 insertions, 2 deletions
diff --git a/dev-cpp/gtest/Manifest b/dev-cpp/gtest/Manifest
index 035005dab218..263c2954cefa 100644
--- a/dev-cpp/gtest/Manifest
+++ b/dev-cpp/gtest/Manifest
@@ -1,3 +1,4 @@
DIST gtest-1.7.0.tar.gz 1001582 BLAKE2B 3d10c1e502c2fac1500d07301031a9328b29027a3f9719137e09d2c47556cf52bbc978a8fb7b37330a94beafa27d24c3bfc247b2f0d51306b53f43e7ae2373b4 SHA512 a9f5c047b39efb2d11b55ee9913662ca402ac6837b3ad2d278ecfbd1caf32ed4546f169e3e92503d57bf3b62ccf89cd062da1c7ea3638aae98e868d2766363c3
DIST gtest-1.8.0.tar.gz 1281617 BLAKE2B ac052b4d0eb0d8ded03a8c7dff05177818627b8a51f2dbc2c162b2ee2a5d1323539e7d0d02236d9ebb799995e018f0171c2fdaeb4de3bb339548265e50de79e6 SHA512 1dbece324473e53a83a60601b02c92c089f5d314761351974e097b2cf4d24af4296f9eb8653b6b03b1e363d9c5f793897acae1f0c7ac40149216035c4d395d9d
DIST gtest-1.8.1.tar.gz 992298 BLAKE2B 40ef3417fe424205c0617f07207347ce671ac87605f8ac9b8a333b0b06e3fbef9f556041ee324c18f957f3258ab9fe06704f31cdd038355fb7890180eb77ced1 SHA512 e6283c667558e1fd6e49fa96e52af0e415a3c8037afe1d28b7ff1ec4c2ef8f49beb70a9327b7fc77eb4052a58c4ccad8b5260ec90e4bceeac7a46ff59c4369d7
+DIST gtest-1.9.0_pre20190607.tar.gz 958396 BLAKE2B 64ae2c86a320a6ed56d6f99383591f7a0176e3f1291144bddf6dc82733c78177963f95516bbaed494318d3d7451d164aeb0d4a192b415414bcc25b9875cf6e82 SHA512 6c17ba303ec1dc8a989075a6dc0eda9b023345d00f6b43e588676cc2cd291f8c508744e4aba86a6c6b651329ce47419ad04d5765ca5978eda507a1643e8a92c3
diff --git a/dev-cpp/gtest/gtest-1.9.0_pre20190607.ebuild b/dev-cpp/gtest/gtest-1.9.0_pre20190607.ebuild
new file mode 100644
index 000000000000..1ff88fb723ff
--- /dev/null
+++ b/dev-cpp/gtest/gtest-1.9.0_pre20190607.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Python is required for tests and some build tasks.
+PYTHON_COMPAT=( python2_7 pypy )
+
+GOOGLETEST_COMMIT=da10da05c262af0a9e8fa91789a272a3dec67655
+
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/google/googletest"
+else
+ if [[ -z ${GOOGLETEST_COMMIT} ]]; then
+ MY_PV=release-${PV}
+ else
+ MY_PV=${GOOGLETEST_COMMIT}
+ fi
+ SRC_URI="https://github.com/google/googletest/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+ S="${WORKDIR}"/googletest-${MY_PV}
+fi
+
+DESCRIPTION="Google C++ Testing Framework"
+HOMEPAGE="https://github.com/google/googletest"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+RDEPEND="!dev-cpp/gmock"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-increase-clone-stack-size.patch
+)
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -i -e '/set(cxx_base_flags /s:-Werror::' \
+ googletest/cmake/internal_utils.cmake || die "sed failed!"
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_GMOCK=ON
+ -DINSTALL_GTEST=ON
+
+ # tests
+ -Dgmock_build_tests=$(usex test)
+ -Dgtest_build_tests=$(usex test)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use doc; then
+ docinto googletest
+ dodoc -r googletest/docs/.
+ docinto googlemock
+ dodoc -r googlemock/docs/.
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc googletest/samples/*.{cc,h}
+ fi
+}
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index 98ce51d82aec..685acf50cd67 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -12,9 +12,14 @@ if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/google/googletest"
else
- SRC_URI="https://github.com/google/googletest/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ if [[ -z ${GOOGLETEST_COMMIT} ]]; then
+ MY_PV=release-${PV}
+ else
+ MY_PV=${GOOGLETEST_COMMIT}
+ fi
+ SRC_URI="https://github.com/google/googletest/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
- S="${WORKDIR}"/googletest-release-${PV}
+ S="${WORKDIR}"/googletest-${MY_PV}
fi
DESCRIPTION="Google C++ Testing Framework"