summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/gtkglextmm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/gtkglextmm')
-rw-r--r--dev-cpp/gtkglextmm/Manifest1
-rw-r--r--dev-cpp/gtkglextmm/gtkglextmm-1.2.0-r1.ebuild43
-rw-r--r--dev-cpp/gtkglextmm/metadata.xml8
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-cpp/gtkglextmm/Manifest b/dev-cpp/gtkglextmm/Manifest
new file mode 100644
index 000000000000..3af4d5be6ae5
--- /dev/null
+++ b/dev-cpp/gtkglextmm/Manifest
@@ -0,0 +1 @@
+DIST gtkglextmm-1.2.0.tar.bz2 623815 SHA256 6cd4bd2a240e5eb1e3a24c5a3ebbf7ed905b522b888439778043fdeb58771fea SHA512 94e66bc295000bb3f3352f58c9848372a4c23586dcc52450806c73e3e0630ab2b51291b347da16bba853b658deb070218203a031d906fc2ff051386dd065aba9 WHIRLPOOL 9d1927136edb226179c7ce356699c4504785a53a40575e43a875f0c9685965405b2632ec7cc98f55f3206ef7d6b25996fc2ad80b1d5c12213644b730fd81791b
diff --git a/dev-cpp/gtkglextmm/gtkglextmm-1.2.0-r1.ebuild b/dev-cpp/gtkglextmm/gtkglextmm-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..78aa178f373b
--- /dev/null
+++ b/dev-cpp/gtkglextmm/gtkglextmm-1.2.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for gtkglext"
+HOMEPAGE="http://projects.gnome.org/gtkglext/"
+SRC_URI="mirror://sourceforge/gtkglext/${P}.tar.bz2"
+
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+SLOT="1.0"
+LICENSE="GPL-2 LGPL-2.1"
+
+RDEPEND="
+ >=x11-libs/gtkglext-1
+ >=dev-libs/libsigc++-2.0
+ >=dev-cpp/glibmm-2.4:2
+ >=dev-cpp/gtkmm-2.4:2.4
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Remove docs from SUBDIRS so that docs are not installed, as
+ # we handle it in src_install.
+ sed -i -e 's|^\(SUBDIRS =.*\)docs\(.*\)|\1\2|' Makefile.in || \
+ die "sed Makefile.in failed"
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ if use doc; then
+ dohtml -r docs/reference/html/*
+ fi
+}
diff --git a/dev-cpp/gtkglextmm/metadata.xml b/dev-cpp/gtkglextmm/metadata.xml
new file mode 100644
index 000000000000..d8abd0a8270d
--- /dev/null
+++ b/dev-cpp/gtkglextmm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-mm</herd>
+ <upstream>
+ <remote-id type="sourceforge">gtkglext</remote-id>
+ </upstream>
+</pkgmetadata>