summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-02-06 17:02:32 -0500
committerMatt Turner <mattst88@gentoo.org>2021-02-15 20:25:23 -0500
commit20a045fef9f4b11286882873a10936bb219be6f2 (patch)
tree694fa75325c4ea5f52caf01a9131a6d9a7fbbc6b /dev-cpp/gtksourceviewmm/gtksourceviewmm-3.18.0-r1.ebuild
parentapp-text/cherrytree: Specify the pangomm slot (diff)
downloadgentoo-20a045fef9f4b11286882873a10936bb219be6f2.tar.gz
gentoo-20a045fef9f4b11286882873a10936bb219be6f2.tar.bz2
gentoo-20a045fef9f4b11286882873a10936bb219be6f2.zip
dev-cpp/gtksourceviewmm: Specify the atkmm+cairomm slots
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/gtksourceviewmm/gtksourceviewmm-3.18.0-r1.ebuild')
-rw-r--r--dev-cpp/gtksourceviewmm/gtksourceviewmm-3.18.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/gtksourceviewmm/gtksourceviewmm-3.18.0-r1.ebuild b/dev-cpp/gtksourceviewmm/gtksourceviewmm-3.18.0-r1.ebuild
new file mode 100644
index 000000000000..a44c29f5fc79
--- /dev/null
+++ b/dev-cpp/gtksourceviewmm/gtksourceviewmm-3.18.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for gtksourceview"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+SLOT="3.0"
+LICENSE="LGPL-2.1"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.46.1:2
+ >=dev-cpp/gtkmm-3.18.0:3.0
+ >=x11-libs/gtksourceview-3.18.0:3.0
+
+ dev-cpp/atkmm:0
+ dev-cpp/cairomm:0
+ dev-cpp/pangomm:1.4
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog* NEWS README"
+ gnome2_src_configure $(use_enable doc documentation)
+}