summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-01-13 22:23:52 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-01-13 22:23:52 +0000
commitcdefa7d2502c86215a7fea4c0c5f16b717302ceb (patch)
tree8c0f0d362164c4c6883bfb72fecd6750fc7be866 /dev-cpp/htmlcxx
parentsys-fs/e2fsprogs: arm64 stable (bug #675346) (diff)
downloadgentoo-cdefa7d2502c86215a7fea4c0c5f16b717302ceb.tar.gz
gentoo-cdefa7d2502c86215a7fea4c0c5f16b717302ceb.tar.bz2
gentoo-cdefa7d2502c86215a7fea4c0c5f16b717302ceb.zip
dev-cpp/htmlcxx: Version bump to 0.87, EAPI 7
I have dropped the flex and yacc dependencies. I think yacc was required before but now a pregenerated file is included and the rule to remake it is missing. I'm not sure whether flex was ever really required. Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-cpp/htmlcxx')
-rw-r--r--dev-cpp/htmlcxx/Manifest1
-rw-r--r--dev-cpp/htmlcxx/htmlcxx-0.87.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-cpp/htmlcxx/Manifest b/dev-cpp/htmlcxx/Manifest
index 8dd6bee776bf..d686b34f837a 100644
--- a/dev-cpp/htmlcxx/Manifest
+++ b/dev-cpp/htmlcxx/Manifest
@@ -1 +1,2 @@
DIST htmlcxx-0.86.tar.gz 469416 BLAKE2B 6edd4b7755db6d8911bc4ee6b1b61792b08d6a381971162a77cd3a6c7cb6cdb06e5a4a77b0a815589edab26aec04490a6b6c9edd80199f01304a506c707688b6 SHA512 dcff9c9946e1c3429af2230997c965b89a28a8ee219d8d594800106ff578bb21154e4680c38a09fb5f96cd4051c89cbf16f2151d30be93d4e3d291ff421aafcb
+DIST htmlcxx-0.87.tar.gz 477083 BLAKE2B 94977e758b4f2643f39a464094e315c11b78bc957a3eb054e6a7608828345704a82c3ca36c5ac2855054e7570daebb80d8a63639f3a7197344d25f2d16830702 SHA512 391b94c7ea2d17a04d46ac80f8146e6c2b14b289379c40f3d432ed9c0f36222ced6384d725cdecfc352e28c30f11976249b6a3f7133bbee3161a7883d197fca7
diff --git a/dev-cpp/htmlcxx/htmlcxx-0.87.ebuild b/dev-cpp/htmlcxx/htmlcxx-0.87.ebuild
new file mode 100644
index 000000000000..fdcb01bc5cf2
--- /dev/null
+++ b/dev-cpp/htmlcxx/htmlcxx-0.87.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="A simple non-validating CSS 1 and HTML parser for C++"
+HOMEPAGE="http://htmlcxx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+ECONF_SOURCE="${S}"
+
+multilib_src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ # libtool archives covered by pkg-config.
+ find "${D}" -name "*.la" -delete || die
+
+ einstalldocs
+}