summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-16 23:47:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-17 00:29:12 +0200
commitc7befb2acb16f58e52e9914826ef4a6c7ca35cad (patch)
treec3266bc398bebd863ab950d8b0cdba191887dfcf /dev-cpp/libcmis/libcmis-9999.ebuild
parentgames-fps/eduke32: drop old version (diff)
downloadgentoo-c7befb2acb16f58e52e9914826ef4a6c7ca35cad.tar.gz
gentoo-c7befb2acb16f58e52e9914826ef4a6c7ca35cad.tar.bz2
gentoo-c7befb2acb16f58e52e9914826ef4a6c7ca35cad.zip
dev-cpp/libcmis: Add new 0.5.2_pre20180118 snapshot
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-cpp/libcmis/libcmis-9999.ebuild')
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index 78e5b1990a3a..922b7a7756a6 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -5,17 +5,14 @@ EAPI=6
if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://github.com/tdf/libcmis.git"
- SCM_ECLASS="git-r3"
+ inherit git-r3
elif [[ ${PV} = *_pre* ]]; then
- SCM_ECLASS="vcs-snapshot"
- snapshot=d2054a12e3f52fff8e96341e8c48f0dcd75e2e2a
- SRC_URI="https://github.com/tdf/${PN}/archive/${snapshot}.tar.gz -> ${P}.tar.gz"
- unset snapshot
+ COMMIT=738528d790b2b1d52d9b72d673842969a852815d
+ SRC_URI="https://github.com/tdf/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
else
SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
-inherit alternatives autotools flag-o-matic ${SCM_ECLASS}
-unset SCM_ECLASS
+inherit alternatives autotools flag-o-matic
DESCRIPTION="C++ client library for the CMIS interface"
HOMEPAGE="https://github.com/tdf/libcmis"
@@ -25,16 +22,16 @@ SLOT="0.5"
# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
IUSE="man static-libs test"
-COMMON_DEPEND="
+RDEPEND="
dev-libs/boost:=
dev-libs/libxml2
net-misc/curl
"
-DEPEND="${COMMON_DEPEND}
+DEPEND="${RDEPEND}
virtual/pkgconfig
man? (
app-text/docbook2X
@@ -45,12 +42,11 @@ DEPEND="${COMMON_DEPEND}
dev-util/cppunit
)
"
-RDEPEND="${COMMON_DEPEND}
- !<dev-cpp/libcmis-0.5.0
-"
RESTRICT="test"
+[[ ${PV} = *_pre* ]] && S="${WORKDIR}/${PN}-${COMMIT}"
+
src_prepare() {
default
[[ ${PV} = *_pre* || ${PV} = 9999 ]] && eautoreconf