summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-07-31 13:49:15 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-09-17 23:32:12 +0200
commitd785e728ba01b0a6858bf3f82ed947ea96ba1fdc (patch)
tree4074847adc26d2e133e8cd2c0474d2a3fdacb752 /dev-cpp/libcmis/libcmis-9999.ebuild
parentmedia-libs/libgltf: Bump to EAPI 6, eliminate base.eclass (diff)
downloadgentoo-d785e728ba01b0a6858bf3f82ed947ea96ba1fdc.tar.gz
gentoo-d785e728ba01b0a6858bf3f82ed947ea96ba1fdc.tar.bz2
gentoo-d785e728ba01b0a6858bf3f82ed947ea96ba1fdc.zip
dev-cpp/libcmis: Add 0.5.2_pre20160820 snapshot
Contains the 2FA fixes necessary to make Google Drive remote access work. No big difference to .1 otherwise. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-cpp/libcmis/libcmis-9999.ebuild')
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index cf54088f06bc..f6c40f8a2d59 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -11,7 +11,14 @@ unset SCM_ECLASS
DESCRIPTION="C++ client library for the CMIS interface"
HOMEPAGE="https://github.com/tdf/libcmis"
-[[ ${PV} == 9999 ]] || SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+if [[ ${PV} = *_pre* ]]; then
+ snapshot=d2054a12e3f52fff8e96341e8c48f0dcd75e2e2a
+ SRC_URI="https://github.com/tdf/${PN}/archive/${snapshot}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${snapshot}"
+ unset snapshot
+elif [[ ${PV} != 9999 ]] ; then
+ SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
SLOT="0.5"
@@ -39,15 +46,12 @@ DEPEND="${COMMON_DEPEND}
)
"
RDEPEND="${COMMON_DEPEND}
- !dev-cpp/libcmis:0
- !dev-cpp/libcmis:0.2
- !dev-cpp/libcmis:0.3
- !dev-cpp/libcmis:0.4
+ !<dev-cpp/libcmis-0.5.0
"
src_prepare() {
- eapply_user
- [[ ${PV} == 9999 ]] && eautoreconf
+ default
+ [[ ${PV} = *_pre* || ${PV} = 9999 ]] && eautoreconf
}
src_configure() {