summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/libxsd-frontend
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/libxsd-frontend')
-rw-r--r--dev-cpp/libxsd-frontend/Manifest1
-rw-r--r--dev-cpp/libxsd-frontend/files/1.17.0-boost-filesystem-v2-deprecation.patch261
-rw-r--r--dev-cpp/libxsd-frontend/libxsd-frontend-1.18.0-r3.ebuild92
-rw-r--r--dev-cpp/libxsd-frontend/metadata.xml8
4 files changed, 362 insertions, 0 deletions
diff --git a/dev-cpp/libxsd-frontend/Manifest b/dev-cpp/libxsd-frontend/Manifest
new file mode 100644
index 000000000000..72d108a37d76
--- /dev/null
+++ b/dev-cpp/libxsd-frontend/Manifest
@@ -0,0 +1 @@
+DIST libxsd-frontend-1.18.0.tar.bz2 66937 SHA256 78382d44ae0575fec04eb2e2e70c2bb751b49eb995aad725d3c2e9ee8ac98590 SHA512 fdff24659037d99ca37a15c2bc33a91e9864d2df20210c13230ab64c3c5ecd7aebefe5c7b3b316812d8f844ca38c297931d74d19a278bf986de80e2f0c54d223 WHIRLPOOL 94f092087f17b0694821ab1f7864fa80639c7daf73e6926d665365d624f46d69d1f74e0de4af901a399593bf52020311614c000d94160505a429728f0d3e2818
diff --git a/dev-cpp/libxsd-frontend/files/1.17.0-boost-filesystem-v2-deprecation.patch b/dev-cpp/libxsd-frontend/files/1.17.0-boost-filesystem-v2-deprecation.patch
new file mode 100644
index 000000000000..cd575a6ccdca
--- /dev/null
+++ b/dev-cpp/libxsd-frontend/files/1.17.0-boost-filesystem-v2-deprecation.patch
@@ -0,0 +1,261 @@
+diff -Naurb -I '^//' -I '^# copyright' -x build libxsd-frontend-1.17.0/tests/dump/driver.cxx xsd-3.3.0-2+dep/libxsd-frontend/tests/dump/driver.cxx
+--- libxsd-frontend-1.17.0/tests/dump/driver.cxx 2010-04-27 21:31:24.000000000 +0200
++++ xsd-3.3.0-2+dep/libxsd-frontend/tests/dump/driver.cxx 2012-08-23 11:30:16.074750804 +0200
+@@ -586,7 +586,11 @@
+
+ // Parse schema.
+ //
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ SemanticGraph::Path path (argv[i], boost::filesystem::native);
++#else
++ SemanticGraph::Path path (argv[i]);
++#endif
+
+ Parser parser (true, false, true);
+ Evptr<SemanticGraph::Schema> tu (parser.parse (path));
+diff -Naurb -I '^//' -I '^# copyright' -x build libxsd-frontend-1.17.0/xsd-frontend/parser.cxx xsd-3.3.0-2+dep/libxsd-frontend/xsd-frontend/parser.cxx
+--- libxsd-frontend-1.17.0/xsd-frontend/parser.cxx 2010-04-27 21:31:24.000000000 +0200
++++ xsd-3.3.0-2+dep/libxsd-frontend/xsd-frontend/parser.cxx 2012-06-03 11:02:29.000000000 +0200
+@@ -1274,7 +1274,11 @@
+ operator () (SemanticGraph::Path const& x,
+ SemanticGraph::Path const& y) const
+ {
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ return x.native_file_string () < y.native_file_string ();
++#else
++ return x.string () < y.string ();
++#endif
+ }
+ };
+
+@@ -1627,9 +1631,15 @@
+ friend Boolean
+ operator< (SchemaId const& x, SchemaId const& y)
+ {
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ return x.path_.native_file_string () < y.path_.native_file_string ()
+ || (x.path_.native_file_string () == y.path_.native_file_string ()
+ && x.ns_ < y.ns_);
++#else
++ return x.path_.string () < y.path_.string ()
++ || (x.path_.string () == y.path_.string ()
++ && x.ns_ < y.ns_);
++#endif
+ }
+
+ private:
+@@ -2376,6 +2386,7 @@
+ Path path, rel_path, abs_path;
+ try
+ {
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ try
+ {
+ path = Path (loc);
+@@ -2386,6 +2397,10 @@
+ //
+ path = Path (loc, boost::filesystem::native);
+ }
++#else
++ // The new ABI does not have a fallback native representation
++ path = Path (loc.c_str());
++#endif
+
+ if (path.is_complete ())
+ {
+@@ -2479,6 +2494,7 @@
+ Path path, rel_path, abs_path;
+ try
+ {
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ try
+ {
+ path = Path (loc);
+@@ -2489,6 +2505,10 @@
+ //
+ path = Path (loc, boost::filesystem::native);
+ }
++#else
++ // The new API does not have a fallback native representation.
++ path = Path (loc.c_str());
++#endif
+
+ if (path.is_complete ())
+ {
+@@ -4674,9 +4694,14 @@
+ return true;
+
+
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ XSDFrontend::SemanticGraph::Path abs_path (
+ XML::transcode_to_narrow (e.getLocation ()->getURI ()),
+ boost::filesystem::native);
++#else
++ XSDFrontend::SemanticGraph::Path abs_path (
++ XML::transcode_to_narrow (e.getLocation ()->getURI ()).c_str());
++#endif
+
+ XSDFrontend::SemanticGraph::Path rel_path (ctx_.file (abs_path));
+
+@@ -4729,8 +4754,12 @@
+ base_ (base),
+ ctx_ (ctx)
+ {
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ setSystemId (XML::XMLChString (
+ String (abs_.native_file_string ())).c_str ());
++#else
++ setSystemId (XML::XMLChString (String (abs_.string ())).c_str ());
++#endif
+ }
+
+ virtual Xerces::BinInputStream*
+@@ -4803,8 +4832,12 @@
+
+ // base_uri should be a valid path by now.
+ //
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ Path base (XML::transcode_to_narrow (base_uri),
+ boost::filesystem::native);
++#else
++ Path base (XML::transcode_to_narrow (base_uri).c_str());
++#endif
+
+ if (prv_id == 0)
+ {
+@@ -4830,6 +4863,7 @@
+ {
+ Path path;
+
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ try
+ {
+ path = Path (path_str);
+@@ -4840,6 +4874,10 @@
+ //
+ path = Path (path_str, boost::filesystem::native);
+ }
++#else
++ // The new ABI does not have a fallback native representation
++ path = Path (path_str.c_str());
++#endif
+
+ Path base_dir (base.branch_path ());
+
+diff -Naurb -I '^//' -I '^# copyright' -x build libxsd-frontend-1.17.0/xsd-frontend/semantic-graph/elements.cxx xsd-3.3.0-2+dep/libxsd-frontend/xsd-frontend/semantic-graph/elements.cxx
+--- libxsd-frontend-1.17.0/xsd-frontend/semantic-graph/elements.cxx 2010-04-27 21:31:24.000000000 +0200
++++ xsd-3.3.0-2+dep/libxsd-frontend/xsd-frontend/semantic-graph/elements.cxx 2012-06-03 11:02:29.000000000 +0200
+@@ -342,5 +342,9 @@
+ std::wostream&
+ operator<< (std::wostream& os, XSDFrontend::SemanticGraph::Path const& path)
+ {
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ return os << path.native_file_string ().c_str ();
++#else
++ return os << path.string ().c_str ();
++#endif
+ }
+diff -Naurb -I '^//' -I '^# copyright' -x build libxsd-frontend-1.17.0/xsd-frontend/transformations/anonymous.cxx xsd-3.3.0-2+dep/libxsd-frontend/xsd-frontend/transformations/anonymous.cxx
+--- libxsd-frontend-1.17.0/xsd-frontend/transformations/anonymous.cxx 2010-04-27 21:31:24.000000000 +0200
++++ xsd-3.3.0-2+dep/libxsd-frontend/xsd-frontend/transformations/anonymous.cxx 2012-06-03 11:02:29.000000000 +0200
+@@ -275,7 +275,11 @@
+ }
+ catch (SemanticGraph::InvalidPath const&)
+ {
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ file_str = file.native_file_string ();
++#else
++ file_str = file.string ();
++#endif
+ }
+
+ String name (
+@@ -358,7 +362,11 @@
+ }
+ catch (SemanticGraph::InvalidPath const&)
+ {
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ file_str = file.native_file_string ();
++#else
++ file_str = file.string ();
++#endif
+ }
+ }
+
+@@ -441,7 +449,11 @@
+ }
+ catch (SemanticGraph::InvalidPath const&)
+ {
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ file_str = file.native_file_string ();
++#else
++ file_str = file.string ();
++#endif
+ }
+
+ String name (
+@@ -639,7 +651,11 @@
+ }
+ catch (SemanticGraph::InvalidPath const&)
+ {
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ file_str = file.native_file_string ();
++#else
++ file_str = file.string ();
++#endif
+ }
+
+ String name (
+diff -Naurb -I '^//' -I '^# copyright' -x build libxsd-frontend-1.17.0/xsd-frontend/transformations/schema-per-type.cxx xsd-3.3.0-2+dep/libxsd-frontend/xsd-frontend/transformations/schema-per-type.cxx
+--- libxsd-frontend-1.17.0/xsd-frontend/transformations/schema-per-type.cxx 2010-04-27 21:31:24.000000000 +0200
++++ xsd-3.3.0-2+dep/libxsd-frontend/xsd-frontend/transformations/schema-per-type.cxx 2012-06-03 11:02:29.000000000 +0200
+@@ -167,7 +167,11 @@
+
+ try
+ {
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ path = Path (file_name);
++#else
++ path = Path (file_name.c_str());
++#endif
+ }
+ catch (InvalidPath const&)
+ {
+@@ -349,6 +353,7 @@
+ //
+ NarrowString abs_path;
+
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ // Try to use the portable representation of the path. If that
+ // fails, fall back to the native representation.
+ //
+@@ -360,9 +365,17 @@
+ {
+ abs_path = path.native_file_string ();
+ }
++#else
++ // The new ABI does not have a fallback native representation
++ abs_path = path.string ();
++#endif
+
+ NarrowString tf (trans_.translate_schema (abs_path));
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ NarrowString file (tf ? tf : path.leaf ());
++#else
++ NarrowString file (tf ? tf : path.filename ().string());
++#endif
+
+ Size p (file.rfind ('.'));
+ NarrowString ext (
+@@ -389,7 +402,11 @@
+
+ try
+ {
++#if !defined(BOOST_FILESYSTEM_VERSION) || BOOST_FILESYSTEM_VERSION == 2
+ (*i)->context ().set ("renamed", SemanticGraph::Path (new_name));
++#else
++ (*i)->context ().set ("renamed", SemanticGraph::Path (new_name.c_str()));
++#endif
+ }
+ catch (SemanticGraph::InvalidPath const&)
+ {
diff --git a/dev-cpp/libxsd-frontend/libxsd-frontend-1.18.0-r3.ebuild b/dev-cpp/libxsd-frontend/libxsd-frontend-1.18.0-r3.ebuild
new file mode 100644
index 000000000000..96d02d9005cf
--- /dev/null
+++ b/dev-cpp/libxsd-frontend/libxsd-frontend-1.18.0-r3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs versionator
+
+DESCRIPTION="A compiler frontend for the W3C XML Schema definition language"
+HOMEPAGE="http://www.codesynthesis.com/projects/libxsd-frontend/"
+SRC_URI="http://www.codesynthesis.com/download/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+
+RDEPEND=">=dev-libs/xerces-c-3
+ >=dev-libs/boost-1.52.0-r1:=[threads]
+ >=dev-cpp/libcult-1.4.6-r1
+ >=dev-cpp/libfrontend-elements-1.1.4"
+DEPEND="${RDEPEND}
+ dev-util/build:0.3"
+
+src_prepare() {
+ epatch "${FILESDIR}/1.17.0-boost-filesystem-v2-deprecation.patch"
+}
+
+src_configure() {
+ mkdir -p \
+ build/{ld,cxx/gnu} \
+ build/import/lib{boost,cult,frontend-elements,xerces-c}
+
+ cat >> build/cxx/configuration-dynamic.make <<- EOF
+cxx_id := gnu
+cxx_optimize := n
+cxx_debug := n
+cxx_rpath := n
+cxx_pp_extra_options :=
+cxx_extra_options := ${CXXFLAGS}
+cxx_ld_extra_options := ${LDFLAGS}
+cxx_extra_libs :=
+cxx_extra_lib_paths :=
+ EOF
+
+ cat >> build/cxx/gnu/configuration-dynamic.make <<- EOF
+cxx_gnu := $(tc-getCXX)
+cxx_gnu_libraries :=
+cxx_gnu_optimization_options :=
+ EOF
+
+ cat >> build/import/libboost/configuration-dynamic.make <<- EOF
+libboost_installed := y
+libboost_system := y
+ EOF
+ cat >> build/import/libcult/configuration-dynamic.make <<- EOF
+libcult_installed := y
+ EOF
+
+ cat >> build/ld/configuration-lib-dynamic.make <<- EOF
+ld_lib_type := shared
+ EOF
+
+ cat >> build/import/libfrontend-elements/configuration-dynamic.make <<- EOF
+libfrontend_elements_installed := y
+ EOF
+
+ cat >> build/import/libxerces-c/configuration-dynamic.make <<- EOF
+libxerces_c_installed := y
+ EOF
+
+ MAKEOPTS+=" verbose=1"
+}
+
+src_install() {
+ dolib.so xsd-frontend/libxsd-frontend.so
+
+ find xsd-frontend -iname "*.cxx" \
+ -o -iname "makefile" \
+ -o -iname "*.o" -o -iname "*.d" \
+ -o -iname "*.m4" -o -iname "*.l" \
+ -o -iname "*.cpp-options" -o -iname "*.so" | xargs rm -f
+ rm -rf xsd-frontend/arch
+
+ insinto /usr/include
+ doins -r xsd-frontend
+
+ dodoc NEWS README
+}
+
+src_test() {
+ export LD_LIBRARY_PATH="${S}/xsd-frontend:${LD_LIBRARY_PATH}"
+ default
+}
diff --git a/dev-cpp/libxsd-frontend/metadata.xml b/dev-cpp/libxsd-frontend/metadata.xml
new file mode 100644
index 000000000000..75dd2ca7d302
--- /dev/null
+++ b/dev-cpp/libxsd-frontend/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>