summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-16 08:41:46 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-16 08:45:31 -0700
commiteaf94a94a55cc33d0e9c52c5365f36c2133fa23c (patch)
tree26ebcd3bc4a8d7849561e0175025af9036a1824a /dev-cpp/nlohmann_json
parentdev-libs/msgpack: version bump to 3.2.1 (diff)
downloadgentoo-eaf94a94a55cc33d0e9c52c5365f36c2133fa23c.tar.gz
gentoo-eaf94a94a55cc33d0e9c52c5365f36c2133fa23c.tar.bz2
gentoo-eaf94a94a55cc33d0e9c52c5365f36c2133fa23c.zip
dev-cpp/nlohmann_json: version bump to 3.7.3
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-cpp/nlohmann_json')
-rw-r--r--dev-cpp/nlohmann_json/Manifest1
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.7.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
index 19aee47939af..e64f5eccd1a1 100644
--- a/dev-cpp/nlohmann_json/Manifest
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -1,2 +1,3 @@
DIST nlohmann_json-3.6.1.tar.gz 118862808 BLAKE2B 257508b33480741bd4438fe928869c0744a5e84806fa4e068b048bfc0e665802a45f31bc740c14f74e7a0384df18b9bba58a0e001750b1a800ea00cd1712b280 SHA512 e0565ccdee34e89a6836a97f039c04a0bac445b44f6f323918ea424b34e4577688a4f4f72d5ef1ec0b53d159bfe87e8e9c97b70ef98231ea463f59f05e16eb2a
DIST nlohmann_json-3.7.0.tar.gz 118868542 BLAKE2B 25191628b737ea5614de85d0fcb4425fcb2d37e6890626e6ba22949430a1c5f827ff17d1cd8245c8e98d0deda617d8268c55caff3017a6b4a2f730e524599311 SHA512 35510a0ee59d847ff9fcd4f4026ef936abb89675884fdd2db808f8349a55073206f764cd4f797deb1b6493ea0e04889505f49483e5b88798011dd5db87e7c87d
+DIST nlohmann_json-3.7.3.tar.gz 119013476 BLAKE2B c10648cacdaf6f82aa2b1db49a412165eb9f3d00fd2b2232531077209c2add27dfebfb9dcd62e6923769411a471778a18a347b524e2ed3cf6f008883333ab8cd SHA512 c416b1e14f1fd695fc30a56127ca6440de4b334858ced54a6424d9d093e4665e74b7048f9ab7253ac02ac870e64a2868c78e6c2d6de80d1bd49e50a850cec865
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.7.3.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.7.3.ebuild
new file mode 100644
index 000000000000..7a43019627da
--- /dev/null
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.7.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="JSON for Modern C++"
+HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
+SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( ChangeLog.md README.md )
+
+S=${WORKDIR}/json-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DJSON_BuildTests=$(usex test)
+ -DJSON_MultipleHeaders=ON
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && emake -C doc
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ cmake_src_install
+ use doc && dodoc -r doc/html
+}