summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 09:58:42 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-09 09:58:42 +0200
commit2df04e9a0178530cd570367604c333372bf4a203 (patch)
tree9367e49e93f24f48397fb88835b8789d5dfe909c /dev-cpp/notcurses
parentdev-cpp/argparse: drop multilib, EAPI 8 (diff)
downloadgentoo-2df04e9a0178530cd570367604c333372bf4a203.tar.gz
gentoo-2df04e9a0178530cd570367604c333372bf4a203.tar.bz2
gentoo-2df04e9a0178530cd570367604c333372bf4a203.zip
dev-cpp/notcurses: drop multilib
No multilib reverse-dependencies. Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/notcurses')
-rw-r--r--dev-cpp/notcurses/notcurses-3.0.5-r1.ebuild (renamed from dev-cpp/notcurses/notcurses-3.0.5.ebuild)17
1 files changed, 7 insertions, 10 deletions
diff --git a/dev-cpp/notcurses/notcurses-3.0.5.ebuild b/dev-cpp/notcurses/notcurses-3.0.5-r1.ebuild
index 7e6e9a6d462f..53d4a8c6d2f4 100644
--- a/dev-cpp/notcurses/notcurses-3.0.5.ebuild
+++ b/dev-cpp/notcurses/notcurses-3.0.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake-multilib
+inherit cmake
DESCRIPTION="Blingful TUIs and character graphics"
HOMEPAGE="https://notcurses.com"
@@ -29,21 +29,18 @@ src_configure() {
-DUSE_QRCODEGEN=OFF
-DUSE_STATIC=OFF
)
- cmake-multilib_src_configure
+ cmake_src_configure
}
-src_compile() {
- cmake-multilib_src_compile
-}
-
-# warning: these will fail if you don't have your (utf8) locale available,
-# or the proper terminfo database for your (hopefully correct) TERM.
src_test() {
- cmake-multilib_src_test
+ ewarn "Tests will fail if you don't have a UTF8 locale available,"
+ ewarn "or if you're missing the proper terminfo database for your TERM."
+
+ cmake_src_test
}
src_install() {
- cmake-multilib_src_install
+ cmake_src_install
# we use this tortured form lest we try, every time we release a
# x.y.1 or x.y.3, to install the source dir as a man page.