summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-05-18 11:45:22 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-05-18 11:45:44 -0700
commitc4e5a39d99e8aeb622be55a9b4b0056238e860f9 (patch)
tree709af32671539d40228de5bd67a19003af9817ef /dev-cpp/opentelemetry-cpp
parentdev-python/hatchling: stable 0.24.0 for hppa, bug #844823 (diff)
downloadgentoo-c4e5a39d99e8aeb622be55a9b4b0056238e860f9.tar.gz
gentoo-c4e5a39d99e8aeb622be55a9b4b0056238e860f9.tar.bz2
gentoo-c4e5a39d99e8aeb622be55a9b4b0056238e860f9.zip
dev-cpp/opentelemetry-cpp: add 1.4.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-cpp/opentelemetry-cpp')
-rw-r--r--dev-cpp/opentelemetry-cpp/Manifest1
-rw-r--r--dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.4.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-cpp/opentelemetry-cpp/Manifest b/dev-cpp/opentelemetry-cpp/Manifest
index 81ee9b9a56ff..6433b1022ab4 100644
--- a/dev-cpp/opentelemetry-cpp/Manifest
+++ b/dev-cpp/opentelemetry-cpp/Manifest
@@ -1 +1,2 @@
DIST opentelemetry-cpp-1.3.0.tar.gz 710030 BLAKE2B 56aa3213fd9c9ac5266197c2ca417f5ff181ca28016033c9320e63122eaf9a53bdb265e1778227a9036bc42f8837755a3009cb23610268bc03b9fb24b3844c82 SHA512 38f613c208ec847c8bf7765732d8198fcc427c293a929945d72c2f739e89d2a0ad36be4d94cc3c1b77fd7b1f1d1e5d8bdb38094a493ba3da3125281cd1016836
+DIST opentelemetry-cpp-1.4.0.tar.gz 722520 BLAKE2B c34867846708218e5ffcff9cdaa275e0c43201f681a68ad697d9f83ac04b7fdc6cdb69d942274cbe200b241e407ba11218c7e92da4f9adf4490e89c06388347f SHA512 a2339c0f9b2dc0d4f1964536a844241436bd68774445a0eab6e89e51965e01d3c40d2aa776d751eb497c50e9fdaa4e0023095efb14c8abbd6bbe23a2596eb3c9
diff --git a/dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.4.0.ebuild b/dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.4.0.ebuild
new file mode 100644
index 000000000000..d37e2bfc376f
--- /dev/null
+++ b/dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The OpenTelemetry C++ Client"
+HOMEPAGE="
+ https://opentelemetry.io/
+ https://github.com/open-telemetry/opentelemetry-cpp
+"
+SRC_URI="https://github.com/open-telemetry/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+jaeger prometheus test"
+
+RDEPEND="
+ net-misc/curl:=
+ dev-libs/thrift:=
+ dev-libs/boost:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-cpp/gtest
+ dev-cpp/benchmark
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ # remove tests the need network
+ "${FILESDIR}/opentelemetry-cpp-1.3.0-tests.patch"
+)
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DCMAKE_POSITION_INDEPENDENT_CODE:BOOL=ON
+ -DBUILD_SHARED_LIBS:BOOL=ON
+ -DBUILD_TESTING:BOOL=$(usex test)
+ -DWITH_JAEGER:BOOL=$(usex jaeger)
+ -DWITH_PROMETHEUS:BOOL=$(usex prometheus)
+ )
+
+ cmake_src_configure
+}