summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-22 11:18:28 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-23 23:42:57 -0400
commit5a0eb973c038e4e33020332c103c7cf4cb28820f (patch)
tree014b907077d49ea891690a31f2e8e57514981d57 /dev-cpp/pangomm
parentdev-cpp/pangomm: Rename IUSE=doc → IUSE=gtk-doc (diff)
downloadgentoo-5a0eb973c038e4e33020332c103c7cf4cb28820f.tar.gz
gentoo-5a0eb973c038e4e33020332c103c7cf4cb28820f.tar.bz2
gentoo-5a0eb973c038e4e33020332c103c7cf4cb28820f.zip
dev-cpp/pangomm: Version bump to 2.46.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/pangomm')
-rw-r--r--dev-cpp/pangomm/Manifest1
-rw-r--r--dev-cpp/pangomm/pangomm-2.46.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/pangomm/Manifest b/dev-cpp/pangomm/Manifest
index b62277b2d44b..7d601652122c 100644
--- a/dev-cpp/pangomm/Manifest
+++ b/dev-cpp/pangomm/Manifest
@@ -1,2 +1,3 @@
DIST pangomm-2.46.2.tar.xz 674892 BLAKE2B ac86ef1a229dca29eeb41d3751128bed56d182cecfc6655a478b5a7473d10782fe98cdfee4db6f5afbfe9fb8adbf0e646004aa69c4c4058191078c7b5716434b SHA512 79cad137ec9f22e57a177332df6c6e735aa3baf81df36fc706e81e7a89f23ce3179337507388f65a0d0a74733990dc3547c50243a4559dfd0bb065b1828c0474
+DIST pangomm-2.46.3.tar.xz 674428 BLAKE2B 241b902e65ebb2cc213f479832503f07daad736e168ad7e841f3a22e8640e0365167cb29122cd1bf7080bf7b283ddb92aa71aee9731ea878a1ef26f88c3796c6 SHA512 c0925f295b372bca7b5ede28476ed00e691911e041632969e5e4c30fcf338bac069ba031d4f48601877524b90af47f5238e444e2de7501f1ff25dcda9dd9a9c8
DIST pangomm-2.50.0.tar.xz 753592 BLAKE2B 0db7d43fe2d23e4cfc2b083a4d832c7875c63a261c6b10c62898bf428351ea7d8d05136a46f9498cdb78c51a0223ca988cbc3481041b997dc5d6a9f16f02ec91 SHA512 844850db93b8c4dab19dd364e674ee3d61b2fcb8e020ab3d314f240065ee17aeceea21e9ddc438a7d09d56410e3f82147a57425f76bb01e26d82872934269477
diff --git a/dev-cpp/pangomm/pangomm-2.46.3.ebuild b/dev-cpp/pangomm/pangomm-2.46.3.ebuild
new file mode 100644
index 000000000000..48219b3829a4
--- /dev/null
+++ b/dev-cpp/pangomm/pangomm-2.46.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for pango"
+HOMEPAGE="https://www.gtkmm.org https://gitlab.gnome.org/GNOME/pangomm"
+
+LICENSE="LGPL-2.1+"
+SLOT="1.4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="gtk-doc"
+
+RDEPEND="
+ >=dev-cpp/cairomm-1.2.2:0[gtk-doc?,${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.48.0:2[gtk-doc?,${MULTILIB_USEDEP}]
+ dev-libs/libsigc++:2[gtk-doc?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.45.1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? (
+ >=dev-cpp/mm-common-1.0.4
+ app-doc/doxygen[dot]
+ dev-libs/libxslt
+ )
+ ${PYTHON_DEPS}
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dmaintainer-mode=false
+ $(meson_native_use_bool gtk-doc build-documentation)
+ )
+ meson_src_configure
+}