summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2021-02-05 14:13:35 +0900
committerJoonas Niilola <juippis@gentoo.org>2021-02-15 09:19:17 +0200
commit5058f39b823e1eb07df9a5aa1d0e3eb2bf3f894a (patch)
tree5b5b0797b85f428458b5e2cb22e6c6f2a3648c2a /dev-cpp/prometheus-cpp
parentdev-lang/php: Stabilize 7.4.15 arm64, #768756 (diff)
downloadgentoo-5058f39b823e1eb07df9a5aa1d0e3eb2bf3f894a.tar.gz
gentoo-5058f39b823e1eb07df9a5aa1d0e3eb2bf3f894a.tar.bz2
gentoo-5058f39b823e1eb07df9a5aa1d0e3eb2bf3f894a.zip
dev-cpp/prometheus-cpp: Version bump to 0.12.1
Closes: https://bugs.gentoo.org/768771 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19340 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp/prometheus-cpp')
-rw-r--r--dev-cpp/prometheus-cpp/Manifest1
-rw-r--r--dev-cpp/prometheus-cpp/prometheus-cpp-0.12.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/prometheus-cpp/Manifest b/dev-cpp/prometheus-cpp/Manifest
index c1993ddc6cfc..be92644e327e 100644
--- a/dev-cpp/prometheus-cpp/Manifest
+++ b/dev-cpp/prometheus-cpp/Manifest
@@ -1,3 +1,4 @@
+DIST prometheus-cpp-0.12.1.tar.gz 53034 BLAKE2B cd7f63e76e53cb45c1a23a9b2caba15f56410acfdac5757138cd63d92188a4515563b6e2b5583cf38743c470804422934db40f21293d2dc25fe09daf6a21b82b SHA512 9f9d7ed5b66ff05642e3b0c12cccbd8e23f2685da857d4d24243dfb85239f5478f651043dbe052ac19be4bd44d71875ad0c492797f9a284bad4d4519e970b19b
DIST prometheus-cpp-0.11.0.tar.gz 51126 BLAKE2B 8c2126bcba405748fa398d9b8aed472ca5ade45049817995836fbdb1a09fc29e4176a17ecafa6b9a26f8fb7b62cb00037815ba300123fa3c7f39faac54e160e8 SHA512 4ab286c49403d09f182038cda9cb3bd1b9dbf7061493ff5355afef6ec4ac6ef109c875306e76ed3776b07d640ad7034538cfbc00474106108500994242b4cde2
DIST prometheus-cpp-0.10.0.tar.gz 49694 BLAKE2B f14232e1dad0376ea8e90c89079c4a6d8f2e9f5661a399d38d6f5001506db6c628cb42a934b40139cbb0d904a63c4b4483e6ed92452f5393365ed4209a236247 SHA512 18938b30143ed29985ee56943fd69e0a221f9d25f04fc611554050ee2786e96d968f7db251cccefcbd0017b61bcd8a7ea05af8f217c8aacd9f0694a4702ddcff
DIST prometheus-cpp-0.9.0.tar.gz 43924 BLAKE2B e2b26b257e44c63ae5bc2a703d0ee9247fd8f093ef58a3b00dec022af9cb56b18d20b74ccdb91899e2385b036c332b62d9959b9258082ca420fecf48926139d5 SHA512 d9d5fbbd8c8aad5dd6a5e872275324d689a0c57199e4158d74e13ea62b286fa71dee01bb4197b906b79792bf1ca4e67a46b5c04621d7070241ac32876f6de891
diff --git a/dev-cpp/prometheus-cpp/prometheus-cpp-0.12.1.ebuild b/dev-cpp/prometheus-cpp/prometheus-cpp-0.12.1.ebuild
new file mode 100644
index 000000000000..0924da8da654
--- /dev/null
+++ b/dev-cpp/prometheus-cpp/prometheus-cpp-0.12.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Prometheus Client Library for Modern C++"
+HOMEPAGE="https://github.com/jupp0r/prometheus-cpp"
+SRC_URI="https://github.com/jupp0r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ net-misc/curl
+ sys-libs/zlib
+ www-servers/civetweb[cxx]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/benchmark
+ dev-cpp/gtest
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PULL=yes
+ -DENABLE_PUSH=yes
+ -DENABLE_COMPRESSION=$(usex zlib)
+ -DENABLE_TESTING=$(usex test)
+ -DUSE_THIRDPARTY_LIBRARIES=OFF
+ )
+
+ cmake_src_configure
+}