summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-10-01 13:48:51 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-10-08 13:02:30 +0300
commit884d96bcab917d649a1aaccee846fe070633881a (patch)
treef70fe9c2da1759a1a75ad3f35102ab61f9cc1300 /dev-cpp/prometheus-cpp
parentapp-crypt/rotix: remove unused patch (diff)
downloadgentoo-884d96bcab917d649a1aaccee846fe070633881a.tar.gz
gentoo-884d96bcab917d649a1aaccee846fe070633881a.tar.bz2
gentoo-884d96bcab917d649a1aaccee846fe070633881a.zip
dev-cpp/prometheus-cpp: Version bump to 0.10.0
Closes: https://bugs.gentoo.org/746026 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17736 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp/prometheus-cpp')
-rw-r--r--dev-cpp/prometheus-cpp/Manifest1
-rw-r--r--dev-cpp/prometheus-cpp/prometheus-cpp-0.10.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-cpp/prometheus-cpp/Manifest b/dev-cpp/prometheus-cpp/Manifest
index 7db715e0f9ac..45b840448118 100644
--- a/dev-cpp/prometheus-cpp/Manifest
+++ b/dev-cpp/prometheus-cpp/Manifest
@@ -1 +1,2 @@
+DIST prometheus-cpp-0.10.0.tar.gz 49694 BLAKE2B f14232e1dad0376ea8e90c89079c4a6d8f2e9f5661a399d38d6f5001506db6c628cb42a934b40139cbb0d904a63c4b4483e6ed92452f5393365ed4209a236247 SHA512 18938b30143ed29985ee56943fd69e0a221f9d25f04fc611554050ee2786e96d968f7db251cccefcbd0017b61bcd8a7ea05af8f217c8aacd9f0694a4702ddcff
DIST prometheus-cpp-0.9.0.tar.gz 43924 BLAKE2B e2b26b257e44c63ae5bc2a703d0ee9247fd8f093ef58a3b00dec022af9cb56b18d20b74ccdb91899e2385b036c332b62d9959b9258082ca420fecf48926139d5 SHA512 d9d5fbbd8c8aad5dd6a5e872275324d689a0c57199e4158d74e13ea62b286fa71dee01bb4197b906b79792bf1ca4e67a46b5c04621d7070241ac32876f6de891
diff --git a/dev-cpp/prometheus-cpp/prometheus-cpp-0.10.0.ebuild b/dev-cpp/prometheus-cpp/prometheus-cpp-0.10.0.ebuild
new file mode 100644
index 000000000000..3cd755921597
--- /dev/null
+++ b/dev-cpp/prometheus-cpp/prometheus-cpp-0.10.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Prometheus Client Library for Modern C++"
+HOMEPAGE="https://github.com/jupp0r/prometheus-cpp"
+SRC_URI="https://github.com/jupp0r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/cppcodec
+ net-misc/curl
+ sys-libs/zlib
+ www-servers/civetweb[cxx]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/benchmark
+ dev-cpp/gtest
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PULL=yes
+ -DENABLE_PUSH=yes
+ -DENABLE_COMPRESSION=$(usex zlib)
+ -DENABLE_TESTING=$(usex test)
+ -DUSE_THIRDPARTY_LIBRARIES=OFF
+ )
+
+ cmake_src_configure
+}