summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-07-26 13:56:14 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-09-06 08:55:18 +0300
commitfbe439d0da459c4ccf6e85976425ce7287a346fa (patch)
treead70a2495d80ae55493e376634d7a40838128ce3 /dev-cpp/prometheus-cpp
parentdev-cpp/benchmark: New package (diff)
downloadgentoo-fbe439d0da459c4ccf6e85976425ce7287a346fa.tar.gz
gentoo-fbe439d0da459c4ccf6e85976425ce7287a346fa.tar.bz2
gentoo-fbe439d0da459c4ccf6e85976425ce7287a346fa.zip
dev-cpp/prometheus-cpp: New package
Bug: https://bugs.gentoo.org/733984 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp/prometheus-cpp')
-rw-r--r--dev-cpp/prometheus-cpp/Manifest1
-rw-r--r--dev-cpp/prometheus-cpp/metadata.xml24
-rw-r--r--dev-cpp/prometheus-cpp/prometheus-cpp-0.9.0.ebuild39
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-cpp/prometheus-cpp/Manifest b/dev-cpp/prometheus-cpp/Manifest
new file mode 100644
index 000000000000..7db715e0f9ac
--- /dev/null
+++ b/dev-cpp/prometheus-cpp/Manifest
@@ -0,0 +1 @@
+DIST prometheus-cpp-0.9.0.tar.gz 43924 BLAKE2B e2b26b257e44c63ae5bc2a703d0ee9247fd8f093ef58a3b00dec022af9cb56b18d20b74ccdb91899e2385b036c332b62d9959b9258082ca420fecf48926139d5 SHA512 d9d5fbbd8c8aad5dd6a5e872275324d689a0c57199e4158d74e13ea62b286fa71dee01bb4197b906b79792bf1ca4e67a46b5c04621d7070241ac32876f6de891
diff --git a/dev-cpp/prometheus-cpp/metadata.xml b/dev-cpp/prometheus-cpp/metadata.xml
new file mode 100644
index 000000000000..ece2117d6db5
--- /dev/null
+++ b/dev-cpp/prometheus-cpp/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ This library aims to enable Metrics-Driven Development for C++ services.
+ It implements the Prometheus Data Model, a powerful abstraction on which
+ to collect and expose metrics. We offer the possibility for metrics to
+ be collected by Prometheus, but other push/pull collections can be added
+ as plugins.
+ </longdescription>
+ <maintainer type="person">
+ <email>vilhelm.gray@gmail.com</email>
+ <name>William Breathitt Gray</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/jupp0r/prometheus-cpp/issues</bugs-to>
+ <doc lang="en">https://jupp0r.github.io/prometheus-cpp/</doc>
+ <remote-id type="github">jupp0r/prometheus-cpp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/prometheus-cpp/prometheus-cpp-0.9.0.ebuild b/dev-cpp/prometheus-cpp/prometheus-cpp-0.9.0.ebuild
new file mode 100644
index 000000000000..3cd755921597
--- /dev/null
+++ b/dev-cpp/prometheus-cpp/prometheus-cpp-0.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Prometheus Client Library for Modern C++"
+HOMEPAGE="https://github.com/jupp0r/prometheus-cpp"
+SRC_URI="https://github.com/jupp0r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/cppcodec
+ net-misc/curl
+ sys-libs/zlib
+ www-servers/civetweb[cxx]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/benchmark
+ dev-cpp/gtest
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PULL=yes
+ -DENABLE_PUSH=yes
+ -DENABLE_COMPRESSION=$(usex zlib)
+ -DENABLE_TESTING=$(usex test)
+ -DUSE_THIRDPARTY_LIBRARIES=OFF
+ )
+
+ cmake_src_configure
+}