summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2021-05-27 01:09:28 -0400
committerNick Sarnie <sarnex@gentoo.org>2021-05-27 01:10:44 -0400
commitc9cfe71fee410185e2fe1a0d20f64dba8e27cd1d (patch)
tree73d2211e9ce77b01b0b17ff82ac2f68f727fa7bc /dev-cpp/robin-hood-hashing
parentnet-im/element-desktop-bin: upgrade 1.7.28 -> 1.7.29 (diff)
downloadgentoo-c9cfe71fee410185e2fe1a0d20f64dba8e27cd1d.tar.gz
gentoo-c9cfe71fee410185e2fe1a0d20f64dba8e27cd1d.tar.bz2
gentoo-c9cfe71fee410185e2fe1a0d20f64dba8e27cd1d.zip
dev-cpp/robin-hood-hashing: Rename package
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'dev-cpp/robin-hood-hashing')
-rw-r--r--dev-cpp/robin-hood-hashing/Manifest1
-rw-r--r--dev-cpp/robin-hood-hashing/metadata.xml15
-rw-r--r--dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.2.ebuild18
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/robin-hood-hashing/Manifest b/dev-cpp/robin-hood-hashing/Manifest
new file mode 100644
index 000000000000..c20aed24881b
--- /dev/null
+++ b/dev-cpp/robin-hood-hashing/Manifest
@@ -0,0 +1 @@
+DIST robin-hood-hashing-3.11.2.tar.gz 170488 BLAKE2B 5fb688f5e21f989456e139b64447393816593ad2a1c3537d067d8ea1717aceaa879e27616657354f62e1466ca491f9d302448a73cddb53c7156a623eb375016b SHA512 5d55f054e29ae34d410eb0103f9f0aa1faf47e313b9f089c73b9c26fd9bedf132f6bb13b4bcd2664309c32fe7e859e346d0a6e7ab7f46b294f9b8db207577795
diff --git a/dev-cpp/robin-hood-hashing/metadata.xml b/dev-cpp/robin-hood-hashing/metadata.xml
new file mode 100644
index 000000000000..c64c3ac674d9
--- /dev/null
+++ b/dev-cpp/robin-hood-hashing/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sarnex@gentoo.org</email>
+ <name>Nick Sarnie</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">martinus/robin-hood-hashing</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.2.ebuild b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.2.ebuild
new file mode 100644
index 000000000000..c45e96621481
--- /dev/null
+++ b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+SRC_URI="https://github.com/martinus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Fast & memory efficient hashtable based on robin hood hashing for C++11/14/17/20"
+HOMEPAGE="https://github.com/martinus/robin-hood-hashing"
+
+LICENSE="MIT"
+SLOT="0"
+
+src_install() {
+ insinto /usr/include
+ doins src/include/robin_hood.h
+}