summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-09-04 11:55:28 +0200
committerDavid Seifert <soap@gentoo.org>2017-09-04 11:55:45 +0200
commit953d20e666f14423bd3f88dad41539a6441927a7 (patch)
treee3544fd5b7094cf54c8316e882f4cb0c65086a41 /dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild
parentnet-analyzer/wireshark: Fix README installation in live ebuild (bug #629706 b... (diff)
downloadgentoo-953d20e666f14423bd3f88dad41539a6441927a7.tar.gz
gentoo-953d20e666f14423bd3f88dad41539a6441927a7.tar.bz2
gentoo-953d20e666f14423bd3f88dad41539a6441927a7.zip
dev-cpp/sparsehash: Remove automagic dep on google-perftools
Closes: https://bugs.gentoo.org/show_bug.cgi?id=585968 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild')
-rw-r--r--dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild b/dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..b043e1800ff6
--- /dev/null
+++ b/dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
+HOMEPAGE="https://github.com/sparsehash/sparsehash"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${P}
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.3-fix-buildsystem.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}