summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Fröhning <misanthropos@gmx.net>2022-01-30 22:41:12 +0100
committerIonen Wolkens <ionen@gentoo.org>2022-02-06 14:33:46 -0500
commit896f48bd1e387673126549442ed3ff50fbb83e60 (patch)
treea3667624e2afc34a93feec485ccc6421d4261b87 /dev-cpp/string-theory
parentapp-emulation/firecracker-bin: Bump to 1.0.0 (diff)
downloadgentoo-896f48bd1e387673126549442ed3ff50fbb83e60.tar.gz
gentoo-896f48bd1e387673126549442ed3ff50fbb83e60.tar.bz2
gentoo-896f48bd1e387673126549442ed3ff50fbb83e60.zip
dev-cpp/string-theory: version bump to 3.5
compiles and works with ja2-straciatella-0.17.0 ionen's note: ran into #800245 with 3.4 but 3.5 fixed it Signed-off-by: Richard Fröhning <misanthropos@gmx.net> Closes: https://bugs.gentoo.org/800245 Closes: https://github.com/gentoo/gentoo/pull/24025 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-cpp/string-theory')
-rw-r--r--dev-cpp/string-theory/Manifest1
-rw-r--r--dev-cpp/string-theory/string-theory-3.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/string-theory/Manifest b/dev-cpp/string-theory/Manifest
index 4d9fac23ce48..7b0df9584b2d 100644
--- a/dev-cpp/string-theory/Manifest
+++ b/dev-cpp/string-theory/Manifest
@@ -1,2 +1,3 @@
DIST string-theory-3.3.tar.gz 588360 BLAKE2B ad87857e6d5e3cad1346b759457b434de7612b97e1b19016b1dfc987ac67f0cab318745b14fe1f432cc921ffb1d33b875a2a62f0bc56d815dd35b405a9f08560 SHA512 86209333dce341078c3b973084bd9f3b8ff2ccac0e07a5e6acf5973bd1cfa420897b531b2d1bd6aba9f5ccc8927f85d91f06796ac0e62ec8a735564a0387d2f4
DIST string-theory-3.4.tar.gz 588522 BLAKE2B 207c490293401829d28590291166bcbeefde4ecb3b70d1cc2751d7582c53cf234b7e01579d3bfbe55681708e4d3e22cedbd6fe96b2fdad1c3ef158bb7a080593 SHA512 36ad82c6da276b7cb66d350ceb4bed2a66f768a6604b2981331ceec6a96d03cc3a7e7e5f733de88ec15e0ea41f99f8657b959a51149c540f530d06268c5657ff
+DIST string-theory-3.5.tar.gz 589905 BLAKE2B c2bc926b8568efc1fbe27861619bd8249ad788297dd537cff393d212b3bb12a529847b740fc8ba82dc28501fb05800eb8debf3e4832cf145b5c13882ac45e900 SHA512 30300155e64ace8197ed531baffe4e835c269ac10d6857ac9f29501e0a1f69965994d6f2fa2e64544e7d441de635e2d370be24efcf00a0d24066730d19f022a6
diff --git a/dev-cpp/string-theory/string-theory-3.5.ebuild b/dev-cpp/string-theory/string-theory-3.5.ebuild
new file mode 100644
index 000000000000..0e9b684ef7c7
--- /dev/null
+++ b/dev-cpp/string-theory/string-theory-3.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A flexible modern C++ library for string manipulation and storage"
+HOMEPAGE="https://github.com/zrax/string_theory/"
+SRC_URI="https://github.com/zrax/string_theory/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/string_theory-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ # Drop -Werror from bundled gtest
+ # bug #766468
+ sed -i -e "s/-Werror//" test/gtest-1.10.0/cmake/internal_utils.cmake || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DST_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}/test" || die
+ ./st_gtests || die
+}