summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-17 23:31:42 +0000
committerSam James <sam@gentoo.org>2022-05-17 23:31:51 +0000
commit42d845c4b4db3e1aead5721ae2d857c8e0fb2ee2 (patch)
treee2ea284e531734b72889dd8609d094556245381f /dev-cpp/termcolor
parentdev-php/smarty: add upstream v4.1.1 with a fix for CVE-2022-29221. (diff)
downloadgentoo-42d845c4b4db3e1aead5721ae2d857c8e0fb2ee2.tar.gz
gentoo-42d845c4b4db3e1aead5721ae2d857c8e0fb2ee2.tar.bz2
gentoo-42d845c4b4db3e1aead5721ae2d857c8e0fb2ee2.zip
dev-cpp/termcolor: add 2.1.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/termcolor')
-rw-r--r--dev-cpp/termcolor/Manifest1
-rw-r--r--dev-cpp/termcolor/termcolor-2.1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-cpp/termcolor/Manifest b/dev-cpp/termcolor/Manifest
index 49924bd31aaa..a52fc8290f29 100644
--- a/dev-cpp/termcolor/Manifest
+++ b/dev-cpp/termcolor/Manifest
@@ -1 +1,2 @@
DIST termcolor-2.0.0.tar.gz 88582 BLAKE2B 3e7a4a99af3586fff103d0de0601e019881745e2921b4750dbf476439138a71120b6513a287c5fe26fd96a9c6115cb82295810d9bea11d0992f48fcd5d0a8d18 SHA512 72dead77fb9f3ff79432b1659b57c3d961a57b46305937acd0c221f5abb016f609dfaf7a9bf508bd7a073338ee604cf55f9915c8e8a76ddfaf6c68bc031e37f9
+DIST termcolor-2.1.0.tar.gz 89041 BLAKE2B 1b3681dcd7dde394737bdc02e8a8ae10c61adfddbb1506e7254c27636a9045bc17ebe45801ecf813c3fc6b3a4bb3ea90bc6246e651105fab2e42b0807fa74339 SHA512 668853a93e1208a08a4ea9ac8db2d9c615cefd0325c35402b767e0b1bf373589507b8eb7685babd5801c1e4f2533db6f4eabfedde365737a4c7c069f00f536d8
diff --git a/dev-cpp/termcolor/termcolor-2.1.0.ebuild b/dev-cpp/termcolor/termcolor-2.1.0.ebuild
new file mode 100644
index 000000000000..62b3a7572734
--- /dev/null
+++ b/dev-cpp/termcolor/termcolor-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A header-only C++ library for printing colored messages to the terminal"
+HOMEPAGE="https://github.com/ikalnytskyi/termcolor https://termcolor.readthedocs.io"
+SRC_URI="https://github.com/ikalnytskyi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+# It's just a visual test, nothing automated / no way to detect failure in an ebuild.
+RESTRICT="!test? ( test ) test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DTERMCOLOR_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/test_termcolor || die
+}