summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-28 13:30:59 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-28 13:31:45 +0200
commitce8e182b10b665cee32f2241891c447ce52348fe (patch)
tree9fbfd8e5de9937ccfe8755e7b04055183ce2450d /dev-cpp/threadpool
parentnet-misc/libss7: Remove last-rited pkg (diff)
downloadgentoo-ce8e182b10b665cee32f2241891c447ce52348fe.tar.gz
gentoo-ce8e182b10b665cee32f2241891c447ce52348fe.tar.bz2
gentoo-ce8e182b10b665cee32f2241891c447ce52348fe.zip
dev-cpp/threadpool: Remove last-rited pkg
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-cpp/threadpool')
-rw-r--r--dev-cpp/threadpool/Manifest2
-rw-r--r--dev-cpp/threadpool/files/threadpool-0.2.5-memleak.patch22
-rw-r--r--dev-cpp/threadpool/metadata.xml11
-rw-r--r--dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild39
4 files changed, 0 insertions, 74 deletions
diff --git a/dev-cpp/threadpool/Manifest b/dev-cpp/threadpool/Manifest
deleted file mode 100644
index 54c68e5c06ea..000000000000
--- a/dev-cpp/threadpool/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST threadpool-0_2_5-doc.zip 154617 BLAKE2B 77d9421236d4964c7d69ca59f700f3697dc2c20852737e94bccc0547ce0c5db2a08715701c954c49ceb3c84644c77b7a2e115aef9c537b16df410011af5cc20b SHA512 cdee7d0cf02af55ef4e1237fff9f5214ffb91b00ad2880592efcf3f62d661f3e8a870d092797dd2866e24189e9d6f8e626ca840ab89ce29e5c944c79e8cb31ea
-DIST threadpool-0_2_5-src.zip 58599 BLAKE2B 00312a1eee427cac3f55e1162f3051e7a4a2a805a941f9bf858088deba696dda38f241d7eb5e57d38f00bec161197cbda70be1cd31465c4031d242d2f2e6ab66 SHA512 961576b619e5227098fa37a3c8d903128b3c2a9cf1e55c057c6f9126062bcccfa6fe2510b4e8ee5d1a0e3d0425f0077c50eccad2120a423f69e2705460780e7c
diff --git a/dev-cpp/threadpool/files/threadpool-0.2.5-memleak.patch b/dev-cpp/threadpool/files/threadpool-0.2.5-memleak.patch
deleted file mode 100644
index 26d89d1d5c25..000000000000
--- a/dev-cpp/threadpool/files/threadpool-0.2.5-memleak.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Fix memleak due circular references blocking garbage collection.
-
-http://www.cplusplus.com/forum/general/56971/ provides a testcase for a memory
-leak with the threadpool due to shared_ptr usage.
-
-I really needed threadpool to work for me, so I traced & fixed it as best as
-possible. When the threadpool is being destroyed, your threads should have
-terminated already. Do so deliberately if not done yet, so that they free the
-memory.
-
-Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-
---- threadpool/boost/threadpool/detail/pool_core.hpp
-+++ threadpool/boost/threadpool/detail/pool_core.hpp
-@@ -150,6 +150,7 @@
- /// Destructor.
- ~pool_core()
- {
-+ terminate_all_workers(true);
- }
-
- /*! Gets the size controller which manages the number of threads in the pool.
diff --git a/dev-cpp/threadpool/metadata.xml b/dev-cpp/threadpool/metadata.xml
deleted file mode 100644
index 2af619160dd4..000000000000
--- a/dev-cpp/threadpool/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>robbat2@gentoo.org</email>
- <name>Robin H. Johnson</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">threadpool</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild b/dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild
deleted file mode 100644
index 882c07045372..000000000000
--- a/dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A cross-platform C++ thread pool library (built on top of Boost)"
-HOMEPAGE="http://threadpool.sourceforge.net/"
-MY_PV=${PV//./_}
-MY_P=${PN}-${MY_PV}
-SRC_URI_BASE="mirror://sourceforge/threadpool/threadpool/${PV}%20%28Stable%29"
-SRC_URI="${SRC_URI_BASE}/${MY_P}-src.zip
- doc? ( ${SRC_URI_BASE}/${MY_P}-doc.zip )"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND="dev-libs/boost"
-
-S="${WORKDIR}/${MY_P}-src/${PN}"
-
-DOCS=( README TODO CHANGE_LOG )
-PATCHES=( "${FILESDIR}/${P}-memleak.patch" )
-
-src_compile() {
- # Do nothing
- # The makefile just builds the documentation again
- # Not even any install targets
- return
-}
-
-src_install() {
- doheader -r boost
-
- use doc && HTML_DOCS+=( "${WORKDIR}"/"${MY_P}"-doc/. )
- einstalldocs
-}