summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-07 18:57:21 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-07 18:57:21 +0200
commit91acb761038d680de8ecd65a78ccc105a0493f7b (patch)
tree788c42c8339dc6f48802f5944a5f76de15eec8f9 /dev-cpp/tree
parentgames-emulation/advancescan: Fix building against GCC 11 (diff)
downloadgentoo-91acb761038d680de8ecd65a78ccc105a0493f7b.tar.gz
gentoo-91acb761038d680de8ecd65a78ccc105a0493f7b.tar.bz2
gentoo-91acb761038d680de8ecd65a78ccc105a0493f7b.zip
dev-cpp/tree: Fix building against GCC 11
Closes: https://bugs.gentoo.org/787614 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/tree')
-rw-r--r--dev-cpp/tree/files/tree-2.81-gcc11.patch33
-rw-r--r--dev-cpp/tree/tree-2.81.ebuild8
2 files changed, 38 insertions, 3 deletions
diff --git a/dev-cpp/tree/files/tree-2.81-gcc11.patch b/dev-cpp/tree/files/tree-2.81-gcc11.patch
new file mode 100644
index 000000000000..2af534dac988
--- /dev/null
+++ b/dev-cpp/tree/files/tree-2.81-gcc11.patch
@@ -0,0 +1,33 @@
+--- "ORIG/simple tree.hpp"
++++ "MOD/simple tree.hpp"
+@@ -323,7 +323,7 @@
+ public:
+ compare_nodes(StrictWeakOrdering comp) : comp_(comp) {};
+
+- bool operator()(const tree_node *a, const tree_node *b)
++ bool operator()(const tree_node *a, const tree_node *b) const
+ {
+ return comp_(a->data, b->data);
+ }
+--- a/tree.hh
++++ b/tree.hh
+@@ -422,7 +422,7 @@
+ public:
+ compare_nodes(StrictWeakOrdering comp) : comp_(comp) {};
+
+- bool operator()(const tree_node *a, const tree_node *b)
++ bool operator()(const tree_node *a, const tree_node *b) const
+ {
+ return comp_(a->data, b->data);
+ }
+--- a/xinlin.hh
++++ b/xinlin.hh
+@@ -332,7 +332,7 @@
+ public:
+ compare_nodes(StrictWeakOrdering comp) : comp_(comp) {};
+
+- bool operator()(const tree_node *a, const tree_node *b)
++ bool operator()(const tree_node *a, const tree_node *b) const
+ {
+ return comp_(a->data, b->data);
+ }
diff --git a/dev-cpp/tree/tree-2.81.ebuild b/dev-cpp/tree/tree-2.81.ebuild
index dc164fccce71..8bf33d70b234 100644
--- a/dev-cpp/tree/tree-2.81.ebuild
+++ b/dev-cpp/tree/tree-2.81.ebuild
@@ -8,15 +8,17 @@ inherit toolchain-funcs
DESCRIPTION="An STL-like tree class"
HOMEPAGE="http://www.aei.mpg.de/~peekas/tree/"
SRC_URI="http://www.aei.mpg.de/~peekas/tree/${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"
KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="doc"
-S="${WORKDIR}/${P}/src"
-
-PATCHES=( "${FILESDIR}"/${P}-test.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-test.patch
+ "${FILESDIR}"/${P}-gcc11.patch
+)
src_configure() {
tc-export CXX