summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2022-08-23 19:27:02 +0200
committerSam James <sam@gentoo.org>2022-08-23 19:56:54 +0100
commit3cc6c155957fceb4367db5a76aa9c5ca91334347 (patch)
tree54d0a35a2a86ffc254d681aea4f905daf21c1c17 /dev-cpp/valijson
parentapp-emulation/virtualbox: add sdl USE flag (diff)
downloadgentoo-3cc6c155957fceb4367db5a76aa9c5ca91334347.tar.gz
gentoo-3cc6c155957fceb4367db5a76aa9c5ca91334347.tar.bz2
gentoo-3cc6c155957fceb4367db5a76aa9c5ca91334347.zip
dev-cpp/valijson: bump to 0.7 & fix test compilation with gcc12
Bug: https://bugs.gentoo.org/866153 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/26988 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/valijson')
-rw-r--r--dev-cpp/valijson/Manifest2
-rw-r--r--dev-cpp/valijson/valijson-0.7.ebuild (renamed from dev-cpp/valijson/valijson-0.6.ebuild)4
2 files changed, 5 insertions, 1 deletions
diff --git a/dev-cpp/valijson/Manifest b/dev-cpp/valijson/Manifest
index ab196e007f5b..7c45f2998533 100644
--- a/dev-cpp/valijson/Manifest
+++ b/dev-cpp/valijson/Manifest
@@ -1 +1 @@
-DIST valijson-0.6.tar.gz 1881386 BLAKE2B 1dd7783e10f7d362673bd2b80920c911cca194068078ac1411897b212600032bc15ffe10dbb62c27e54d168a1c634d73ee40b394e4d534e72224694ec662e0a6 SHA512 a493d17159e479be7fe29d45c610c7d4fdd2c2f9ba897923129734fb07257dbb41fddde4c4263dbf0aa5c7101cd1555568a048beba2f60d2b32e625dd9690749
+DIST valijson-0.7.tar.gz 2060214 BLAKE2B d2e1c58e37213e44d7d6af173691cad3853e87648948c229ea683bfcba8b19256b0230852b0537c2dbdd7084fcf1ac068e320c5f59a69e446610390b82e76474 SHA512 662e53bf1cac4def19792392cda7cbfe2cbadf77b768eb69b2dec693b16f85f32fa2e9b97eae36569cfcc9ac45f1e6338967423cf415d6bcd90372bc49793a2d
diff --git a/dev-cpp/valijson/valijson-0.6.ebuild b/dev-cpp/valijson/valijson-0.7.ebuild
index 879b255f1760..52fc96a2bad8 100644
--- a/dev-cpp/valijson/valijson-0.6.ebuild
+++ b/dev-cpp/valijson/valijson-0.7.ebuild
@@ -21,11 +21,15 @@ src_configure() {
)
if use test; then
+ # Fix relative paths to test data
sed -i -e "s:../tests/data/documents/:../${P}/tests/data/documents/:" tests/test_adapter_comparison.cpp || die
sed -i -e "s:../tests/data:../${P}/tests/data:" tests/test_validation_errors.cpp || die
sed -i -e "s:../thirdparty/:../${P}/thirdparty/:" -e "s:../doc/schema/:../${P}/doc/schema/:" tests/test_validator.cpp || die
fi
+ # -Werror is too aggressive due to false positives with gcc-12, see bug #866153
+ sed -i -e 's/-Werror//g' ../${P}/CMakeLists.txt || die
+
cmake_src_configure
}