summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-06-27 11:32:48 +0200
committerJohannes Huber <johu@gentoo.org>2018-06-27 11:36:27 +0200
commita55bc34dbeda74f9ad1d6b4bf525e1327ec094bc (patch)
tree5cafc73549c41f3f5e7a5e2b4073578ba98b8c37 /dev-cpp/websocketpp/files
parentsys-devel/clang-runtime: Bump to 6.0.1 (diff)
downloadgentoo-a55bc34dbeda74f9ad1d6b4bf525e1327ec094bc.tar.gz
gentoo-a55bc34dbeda74f9ad1d6b4bf525e1327ec094bc.tar.bz2
gentoo-a55bc34dbeda74f9ad1d6b4bf525e1327ec094bc.zip
dev-cpp/websocketpp: Fix cmake install path
Revision bump adds patch by me to fix install paths. Reported-by: Balint SZENTE <balint@szentedwg.ro> Closes: https://bugs.gentoo.org/658096 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-cpp/websocketpp/files')
-rw-r--r--dev-cpp/websocketpp/files/websocketpp-0.7.0-cmake-install.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-cpp/websocketpp/files/websocketpp-0.7.0-cmake-install.patch b/dev-cpp/websocketpp/files/websocketpp-0.7.0-cmake-install.patch
new file mode 100644
index 000000000000..4548c650759d
--- /dev/null
+++ b/dev-cpp/websocketpp/files/websocketpp-0.7.0-cmake-install.patch
@@ -0,0 +1,28 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f60caa1..9ff2211 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -15,13 +15,20 @@ set (WEBSOCKETPP_VERSION ${WEBSOCKETPP_MAJOR_VERSION}.${WEBSOCKETPP_MINOR_VERSIO
+
+ set_property(GLOBAL PROPERTY USE_FOLDERS ON)
+
++get_property(LIB64 GLOBAL PROPERTY FIND_LIBRARY_USE_LIB64_PATHS)
++if ("${LIB64}" STREQUAL "TRUE")
++ set(LIBSUFFIX 64)
++else()
++ set(LIBSUFFIX "")
++endif()
++
+ set(INSTALL_INCLUDE_DIR include CACHE PATH "Installation directory for header files")
++set(LIB_INSTALL_DIR "lib${LIB_SUFFIX}")
+ if (WIN32 AND NOT CYGWIN)
+- set (DEF_INSTALL_CMAKE_DIR cmake)
++ set (INSTALL_CMAKE_DIR cmake)
+ else ()
+- set (DEF_INSTALL_CMAKE_DIR lib/cmake/websocketpp)
++ set (INSTALL_CMAKE_DIR ${LIB_INSTALL_DIR}/cmake/websocketpp)
+ endif ()
+-set (INSTALL_CMAKE_DIR ${DEF_INSTALL_CMAKE_DIR} CACHE PATH "Installation directory for CMake files")
+
+ # Make relative paths absolute (needed later on)
+ foreach (p INCLUDE CMAKE)