summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-02-27 04:36:53 +0100
committerJohannes Huber <johu@gentoo.org>2016-03-08 18:36:59 +0100
commit7e4d680f3eacc8d37b54f869754c976e29c692f3 (patch)
tree45fd4f898b717bd195cbf39d2f027d9b358b1f07 /dev-cpp/websocketpp/websocketpp-0.7.0.ebuild
parentkde-frameworks: Restore stable versions (diff)
downloadgentoo-7e4d680f3eacc8d37b54f869754c976e29c692f3.tar.gz
gentoo-7e4d680f3eacc8d37b54f869754c976e29c692f3.tar.bz2
gentoo-7e4d680f3eacc8d37b54f869754c976e29c692f3.zip
dev-cpp/websocketpp: Version bump 0.7.0
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-cpp/websocketpp/websocketpp-0.7.0.ebuild')
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.7.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/websocketpp/websocketpp-0.7.0.ebuild b/dev-cpp/websocketpp/websocketpp-0.7.0.ebuild
new file mode 100644
index 000000000000..38e0e1eb8552
--- /dev/null
+++ b/dev-cpp/websocketpp/websocketpp-0.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="C++/Boost Asio based websocket client/server library"
+HOMEPAGE="http://www.zaphoyd.com/websocketpp"
+SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+IUSE="boost examples test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ boost? ( dev-libs/boost )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CPP11="$(usex !boost)"
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use examples && DOCS=( examples/ )
+ cmake-utils_src_install
+}