summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-06-28 17:21:41 -0600
committerTim Harder <radhermit@gentoo.org>2019-06-28 17:24:48 -0600
commit0682016ae2e1edbdfa11c73ce44cd0f981a91a0e (patch)
tree57052d2867dfe8048f1e173a5e9f637c68700725 /dev-cpp
parentapp-crypt/p11-kit: version bump (diff)
downloadgentoo-0682016ae2e1edbdfa11c73ce44cd0f981a91a0e.tar.gz
gentoo-0682016ae2e1edbdfa11c73ce44cd0f981a91a0e.tar.bz2
gentoo-0682016ae2e1edbdfa11c73ce44cd0f981a91a0e.zip
dev-cpp/nlohmann_json: install non-amalgamated headers
Also, use cmake for building instead of meson. Closes: https://bugs.gentoo.org/684280 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
new file mode 100644
index 000000000000..13acfc9d9c82
--- /dev/null
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="JSON for Modern C++"
+HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
+SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( ChangeLog.md README.md )
+
+S=${WORKDIR}/json-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DJSON_BuildTests=$(usex test)
+ -DJSON_MultipleHeaders=ON
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && emake -C doc
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc -r doc/html
+}