summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-18 09:15:59 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-18 09:16:23 +0100
commit1b8beeec1cfe80b8203081d214b98b4e3f4952d2 (patch)
tree8789b9d5fc9d68253dff693a03349357a8bafc09 /dev-cpp
parentnet-analyzer/traceroute-nanog: keyword ~arm. (diff)
downloadgentoo-1b8beeec1cfe80b8203081d214b98b4e3f4952d2.tar.gz
gentoo-1b8beeec1cfe80b8203081d214b98b4e3f4952d2.tar.bz2
gentoo-1b8beeec1cfe80b8203081d214b98b4e3f4952d2.zip
dev-cpp/commoncpp2: Pin subslots and remove REQUIRED_USE
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.8.1-r2.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.8.1-r2.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.8.1-r2.ebuild
index 4cf63531e580..7fbd5cc198e0 100644
--- a/dev-cpp/commoncpp2/commoncpp2-1.8.1-r2.ebuild
+++ b/dev-cpp/commoncpp2/commoncpp2-1.8.1-r2.ebuild
@@ -13,14 +13,18 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="debug doc examples ipv6 gnutls ssl static-libs"
-REQUIRED_USE="gnutls? ( ssl )"
-RDEPEND="ssl? ( gnutls? ( dev-libs/libgcrypt:0
- net-libs/gnutls )
- !gnutls? ( dev-libs/openssl:0 ) )
- sys-libs/zlib"
-DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
- ${RDEPEND}"
+RDEPEND="
+ sys-libs/zlib
+ ssl? (
+ gnutls? (
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls:=
+ )
+ !gnutls? ( dev-libs/openssl:0= )
+ )"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.3.6 )"
PATCHES=(
"${FILESDIR}/1.8.1-configure_detect_netfilter.patch"
@@ -38,19 +42,14 @@ src_prepare() {
}
src_configure() {
- local myconf
- if use gnutls; then
- myconf+="--with-gnutls"
- else
- use ssl && myconf+="--with-openssl"
- fi
+ use ssl && local myconf=( $(usex gnutls '--with-gnutls' '--with-openssl') )
econf \
$(use_enable debug) \
$(use_with ipv6) \
$(use_enable static-libs static) \
$(use_with doc doxygen) \
- ${myconf}
+ "${myconf[@]}"
}
src_install () {