summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-07 07:30:21 +0000
committerSam James <sam@gentoo.org>2022-03-07 07:30:49 +0000
commit645f50f395cc89de20897fcd27d6d5414cf183af (patch)
treed34dbea3035c447e83b2e0eaf700fd89d3337497 /dev-cpp
parentnet-libs/libtorrent-rasterbar: drop broken USE=gnutls (diff)
downloadgentoo-645f50f395cc89de20897fcd27d6d5414cf183af.tar.gz
gentoo-645f50f395cc89de20897fcd27d6d5414cf183af.tar.bz2
gentoo-645f50f395cc89de20897fcd27d6d5414cf183af.zip
dev-cpp/folly: BDEPEND on Clang for tests
Did this in one of the other ebuilds (which I ended up not committing for now as unneeded deps) but not this one apparently. Oops. Closes: https://bugs.gentoo.org/834703 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/folly/folly-2022.02.28.00.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/dev-cpp/folly/folly-2022.02.28.00.ebuild b/dev-cpp/folly/folly-2022.02.28.00.ebuild
index d9c4c5003e07..b644181fecc6 100644
--- a/dev-cpp/folly/folly-2022.02.28.00.ebuild
+++ b/dev-cpp/folly/folly-2022.02.28.00.ebuild
@@ -36,6 +36,7 @@ RDEPEND="app-arch/bzip2
# libiberty is linked statically
DEPEND="${RDEPEND}
sys-libs/binutils-libs"
+BDEPEND="test? ( sys-devel/clang )"
pkg_setup() {
if use test && [[ ${BUILD_TYPE} != "binary" ]] && ! tc-is-clang ; then