summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-04-02 21:53:51 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-04-02 21:53:51 +0100
commita050752ec632ed0e462b3195648ed2869bb0eca8 (patch)
treec4bb6787530b8d63935846cb501ed47cbec34e27 /dev-cpp
parentapp-admin/terraform: add 1.1.7 (diff)
downloadgentoo-a050752ec632ed0e462b3195648ed2869bb0eca8.tar.gz
gentoo-a050752ec632ed0e462b3195648ed2869bb0eca8.tar.bz2
gentoo-a050752ec632ed0e462b3195648ed2869bb0eca8.zip
dev-cpp/sdbus-c++: Fix systemd SRC_URI
systemd is confusing. Closes: https://bugs.gentoo.org/836655 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sdbus-c++/Manifest2
-rw-r--r--dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r2.ebuild (renamed from dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r1.ebuild)4
-rw-r--r--dev-cpp/sdbus-c++/sdbus-c++-1.1.0-r2.ebuild (renamed from dev-cpp/sdbus-c++/sdbus-c++-1.1.0-r1.ebuild)4
3 files changed, 5 insertions, 5 deletions
diff --git a/dev-cpp/sdbus-c++/Manifest b/dev-cpp/sdbus-c++/Manifest
index a1645906706d..a60935fdd790 100644
--- a/dev-cpp/sdbus-c++/Manifest
+++ b/dev-cpp/sdbus-c++/Manifest
@@ -1,4 +1,4 @@
DIST sdbus-c++-0.9.0.tar.gz 198979 BLAKE2B 31cda7ce97aad05f93a015ca0f8bd93aa095f6abb6bc513343767c7221d2aeacc96ee2b6a1b0ecf50850f17506fc97aa3a9fead0332687d57bdbddf806502826 SHA512 8695d3efac5654cb28998cdd69c16f251654b2c95e0dc2a2f5a4b01b24dae7b04e1a1f2e9bc9fb96b99f099dd4a130ca980cb672f74829565fd0d48162a581c5
DIST sdbus-c++-1.1.0.tar.gz 201532 BLAKE2B 3dac74cb7fc6717db9d25463ddfb9122db54edcd3bc9d1e71d18c132ede1efaf12b514f335c3978f51277afff7e6ab5533cfd02241759f7e3d24cede8aa29c6d SHA512 ba6230c0d1019875d92a92f793278c528a01692dc70e7acee8bb289af5dae65c1ad7b1c139f859cb7a960c7b48501178bfdf755163c2bc4d3766e67f3aa9b883
DIST systemd-musl-patches-249.5-r1.tar.xz 25148 BLAKE2B 6717291b5335997dcc327764beffc4ded50a5ac0e777bb3c540b5e355bee419c3d9b4a5605c239392d4c1b0e70792bc87282fa15dc9c09a0465b5608f2909006 SHA512 4bb7566437c280e75402fc435a3437aedad127f7b94c9bd54b94e9e1e7507409ad0898681f23e813b9b47414f58e4ca413b6d4e520bbbf578faec09054bf7f9b
-DIST systemd-stable-249.5.tar.gz 10597897 BLAKE2B 5c573322ef9bcd9d019776d6e2d8625a741c1535c0d06661b5666c2438a70cfc4dc182919bb419829de27a4d93c16717ce24e668faf9bd6b09e57f8bd88be725 SHA512 d6f1a5a6f03f0ed05b111aee75da509c5868c523af6209f33e630724dd0c7e0d0abf16920795d587e6c31a5915d247ebc613cf26d4aecf39f82ebb0690fab75f
+DIST systemd-stable-249.11.tar.gz 10622702 BLAKE2B aa3a327ba8de73dd2ac5ecbd9065f2ca4ed56702d6bbd19de43580e6d56211be58ec7678c1609d843f7e960b71b251e0b7080c49338942cd3071076fa02f7acb SHA512 fed7f81933648945a4bfac9fb12150ecd84d32181f79be0e14e0b3a789343a87569f868670e0b8dfc2801fab39f7490f95ee8c29ba831d7611f78c14ace5ddd8
diff --git a/dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r1.ebuild b/dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r2.ebuild
index fde2a90c6d5e..0dcc953b32f4 100644
--- a/dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r1.ebuild
+++ b/dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r2.ebuild
@@ -6,14 +6,14 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
inherit python-any-r1 meson cmake
-SDP="systemd-stable-249.5"
+SDP="systemd-stable-249.11"
MUSL_PATCHSET="249.5-r1"
DESCRIPTION="High-level C++ D-Bus library"
HOMEPAGE="https://github.com/Kistler-Group/sdbus-cpp"
SRC_URI="https://github.com/Kistler-Group/sdbus-cpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
!systemd? (
- https://github.com/systemd/systemd/archive/v${SDP##*-}/${SDP}.tar.gz
+ https://github.com/systemd/${SDP%-*}/archive/v${SDP##*-}/${SDP}.tar.gz
elibc_musl? (
https://dev.gentoo.org/~gyakovlev/distfiles/systemd-musl-patches-${MUSL_PATCHSET}.tar.xz
https://dev.gentoo.org/~soap/distfiles/systemd-musl-patches-${MUSL_PATCHSET}.tar.xz
diff --git a/dev-cpp/sdbus-c++/sdbus-c++-1.1.0-r1.ebuild b/dev-cpp/sdbus-c++/sdbus-c++-1.1.0-r2.ebuild
index df550152fd34..acaaad6ab19a 100644
--- a/dev-cpp/sdbus-c++/sdbus-c++-1.1.0-r1.ebuild
+++ b/dev-cpp/sdbus-c++/sdbus-c++-1.1.0-r2.ebuild
@@ -6,14 +6,14 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
inherit python-any-r1 meson cmake
-SDP="systemd-stable-249.5"
+SDP="systemd-stable-249.11"
MUSL_PATCHSET="249.5-r1"
DESCRIPTION="High-level C++ D-Bus library"
HOMEPAGE="https://github.com/Kistler-Group/sdbus-cpp"
SRC_URI="https://github.com/Kistler-Group/sdbus-cpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
!systemd? (
- https://github.com/systemd/systemd/archive/v${SDP##*-}/${SDP}.tar.gz
+ https://github.com/systemd/${SDP%-*}/archive/v${SDP##*-}/${SDP}.tar.gz
elibc_musl? (
https://dev.gentoo.org/~gyakovlev/distfiles/systemd-musl-patches-${MUSL_PATCHSET}.tar.xz
https://dev.gentoo.org/~soap/distfiles/systemd-musl-patches-${MUSL_PATCHSET}.tar.xz