summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2020-01-08 22:48:23 +0100
committerJohannes Huber <johu@gentoo.org>2020-01-08 22:48:23 +0100
commitb1ef07fb842286f6d0ae5dd7f5c5a9b3f10bd842 (patch)
treead118576893c4f40033e2733c73d66038ecbbc8f /dev-cpp
parentdev-libs/nettle: We (base-system) have gnutls so taking this one too (diff)
downloadgentoo-b1ef07fb842286f6d0ae5dd7f5c5a9b3f10bd842.tar.gz
gentoo-b1ef07fb842286f6d0ae5dd7f5c5a9b3f10bd842.tar.bz2
gentoo-b1ef07fb842286f6d0ae5dd7f5c5a9b3f10bd842.zip
dev-cpp/yaml-cpp: Remove 0.6.3 (r0)
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/yaml-cpp/yaml-cpp-0.6.3.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-cpp/yaml-cpp/yaml-cpp-0.6.3.ebuild b/dev-cpp/yaml-cpp/yaml-cpp-0.6.3.ebuild
deleted file mode 100644
index cc5377b8d0fb..000000000000
--- a/dev-cpp/yaml-cpp/yaml-cpp-0.6.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS="cmake"
-inherit cmake-multilib
-
-DESCRIPTION="YAML parser and emitter in C++"
-HOMEPAGE="https://github.com/jbeder/yaml-cpp"
-SRC_URI="https://github.com/jbeder/${PN}/archive/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/0.6"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# test breaks build
-# RESTRICT="!test? ( test )"
-RESTRICT+="test"
-
-DEPEND="test? ( dev-cpp/gtest )"
-
-S="${WORKDIR}/${PN}-${P}"
-
-src_prepare() {
- sed -i \
- -e 's:INCLUDE_INSTALL_ROOT_DIR:INCLUDE_INSTALL_DIR:g' \
- yaml-cpp.pc.cmake || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DYAML_BUILD_SHARED_LIBS=ON
- -DYAML_CPP_BUILD_TOOLS=OFF # Don't have install rule
- -DYAML_CPP_BUILD_TESTS=$(usex test)
- )
-
- cmake-multilib_src_configure
-}