summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-09-27 17:30:37 +0200
committerMichał Górny <mgorny@gentoo.org>2016-09-27 17:39:41 +0200
commitd8f7e472b80c364d043ffe86455a7c18ace9f4af (patch)
tree0bc26133093a0b47772dcb1d28f71b8d57ccf273 /dev-cpp
parentapp-emulation/vagrant: set permissions on authorized_keys, fixes #592996 (diff)
downloadgentoo-d8f7e472b80c364d043ffe86455a7c18ace9f4af.tar.gz
gentoo-d8f7e472b80c364d043ffe86455a7c18ace9f4af.tar.bz2
gentoo-d8f7e472b80c364d043ffe86455a7c18ace9f4af.zip
dev-cpp/catch: Bump to 1.5.7
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/catch/Manifest1
-rw-r--r--dev-cpp/catch/catch-1.5.7.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-cpp/catch/Manifest b/dev-cpp/catch/Manifest
index 67170b54fe61..eda78d369b57 100644
--- a/dev-cpp/catch/Manifest
+++ b/dev-cpp/catch/Manifest
@@ -1,2 +1,3 @@
DIST Catch-1.5.6.tar.gz 312250 SHA256 1749521eb5c4b6e81128f60d66b81b8328e76050599a497dc8b51a718d03faca SHA512 da4f9c300bc7d9de66be4e0b013d4c5719ee6e112c1b949963fecf55d89d75605bad16d4763ebb4dbaee51dc8c85d2aeb8e7826388204f9d8057233231ff7b9a WHIRLPOOL 38ffdf58959ccb5201621eb4c16b6415b7a892803bc9bdcc134e7f61d82b285b9dfea1f2cf55529c72e0f96dc32696646f0b2d03e8532b03f44de28c3016c7d6
+DIST Catch-1.5.7.tar.gz 312824 SHA256 9acabf466e64ef2d477d4ce8d16610db3556a58b150440025fb1b25c3fd6a85b SHA512 724e85fbcb1a5ff8e98ef04932f7c60f43c0deaf4e41e4790cb7c0d9ead7b2e9068c801b165c094d68373b906c9d2d09de269bd7065dbd0136ecbb18ced4ccff WHIRLPOOL b0ce83cc75bbe40f3531c898fc273101a9992f5b7b43b9a483bf694b7c2fb079808f4330795fa1ae8bb5052fd55feb656245fc503f43217b42cf6239b620b167
DIST catch-1.5.0.tar.gz 311787 SHA256 f694634bc56422f28d61052eedc29d43ea20e60a1726eda3ff9acc8fdfca3c08 SHA512 d7011cdfe6eca86aa081b5da371665be8687bcbb41f3702c3075bf01f73e1d2e00894a0917e6437a8735e730ff287a06e189ce94ea00e583ab7282065f25166d WHIRLPOOL 90d7d6d2f4b06169224385e0f2ec0de1312c454a0c7a2a14155f68fe30424e527cde91e5fb4ff9bd441fa846a7caabca023e591ce5837f6c65f0bbe106166401
diff --git a/dev-cpp/catch/catch-1.5.7.ebuild b/dev-cpp/catch/catch-1.5.7.ebuild
new file mode 100644
index 000000000000..15572fe776f0
--- /dev/null
+++ b/dev-cpp/catch/catch-1.5.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/philsquared/Catch"
+SRC_URI="https://github.com/philsquared/Catch/archive/v${PV}.tar.gz -> ${P^}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P^}
+CMAKE_USE_DIR=${S}/projects/CMake
+
+# CMake is only used to build & run tests, so override phases
+src_configure() { :; }
+src_compile() { :; }
+
+src_test() {
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test
+}
+
+src_install() {
+ # same location as used in fedora
+ insinto /usr/include/catch
+ doins -r include/.
+ dodoc -r docs/.
+}