summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-12-23 21:06:33 +0000
committerMike Gilbert <floppym@gentoo.org>2019-12-29 14:31:34 -0500
commite7e7c080bf7e86752b96b882e4d7ede6db33409e (patch)
tree84ca85212d99f2774849de9be69238d4f8e3d339 /dev-cpp
parentdev-cpp/glog: Set maintainer Arfrever. (diff)
downloadgentoo-e7e7c080bf7e86752b96b882e4d7ede6db33409e.tar.gz
gentoo-e7e7c080bf7e86752b96b882e4d7ede6db33409e.tar.bz2
gentoo-e7e7c080bf7e86752b96b882e4d7ede6db33409e.zip
dev-cpp/glog: Restore "gflags" USE flag.
Fixes: 928b17486c5c731485befc769175476ee877c6fb Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/glog/glog-0.4.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-cpp/glog/glog-0.4.0.ebuild b/dev-cpp/glog/glog-0.4.0.ebuild
index c5097b33e782..77e95ec572fa 100644
--- a/dev-cpp/glog/glog-0.4.0.ebuild
+++ b/dev-cpp/glog/glog-0.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2011-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -12,10 +12,11 @@ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs test"
+IUSE="gflags static-libs test"
RESTRICT="test"
-RDEPENDS="sys-libs/libunwind[${MULTILIB_USEDEP}]"
+RDEPENDS="sys-libs/libunwind[${MULTILIB_USEDEP}]
+ gflags? ( dev-cpp/gflags[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )"
@@ -32,7 +33,8 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
- $(use_enable static-libs static)
+ $(use_enable static-libs static) \
+ ac_cv_lib_gflags_main="$(usex gflags)"
}
multilib_src_install_all() {