summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-04-12 07:36:42 +0300
committerMart Raudsepp <leio@gentoo.org>2017-04-12 07:37:23 +0300
commite99fef041b5cbe5a672d6312699859a03ce4ec96 (patch)
treeb7c2c3dd152629b926c70682afc6828cf586e9f9 /dev-cpp
parentmedia-video/subtitleeditor: update metadata longdescription (diff)
downloadgentoo-e99fef041b5cbe5a672d6312699859a03ce4ec96.tar.gz
gentoo-e99fef041b5cbe5a672d6312699859a03ce4ec96.tar.bz2
gentoo-e99fef041b5cbe5a672d6312699859a03ce4ec96.zip
dev-cpp/gstreamermm: fix compilation with newer gcc
Also filter out -Werror for tests compilation, but those fail to compile further along then. Gentoo-bug: 600296
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gstreamermm/files/1.4.3-fix-compile.patch23
-rw-r--r--dev-cpp/gstreamermm/gstreamermm-1.4.3.ebuild6
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-cpp/gstreamermm/files/1.4.3-fix-compile.patch b/dev-cpp/gstreamermm/files/1.4.3-fix-compile.patch
new file mode 100644
index 000000000000..6ccf0e13ce00
--- /dev/null
+++ b/dev-cpp/gstreamermm/files/1.4.3-fix-compile.patch
@@ -0,0 +1,23 @@
+From c5006faf05bc4b46767d30f42bcb6157836b7540 Mon Sep 17 00:00:00 2001
+From: Marcin Kolny <marcin.kolny@gmail.com>
+Date: Sat, 17 Sep 2016 22:49:34 +0200
+Subject: Fix warnings
+
+---
+ gstreamer/gstreamermm/check.cc | 2 +-
+
+leio: Trimmed patch down to only ThrowIf that makes compilation fail with newer gcc, not just warn
+
+diff --git a/gstreamer/gstreamermm/check.cc b/gstreamer/gstreamermm/check.cc
+index d620435..a0d323d 100644
+--- a/gstreamer/gstreamermm/check.cc
++++ b/gstreamer/gstreamermm/check.cc
+@@ -54,7 +54,7 @@ RefPtr<Element> Check::_Check::setup_element (const ustring& factory)
+
+ element = ElementFactory::create_element (factory, factory);
+
+- ThrowIf (element, "Could not create a '" + factory + "' element");
++ ThrowIf (!!element, "Could not create a '" + factory + "' element");
+ CheckRefCount (element->gobj(), factory, 1);
+
+ return element;
diff --git a/dev-cpp/gstreamermm/gstreamermm-1.4.3.ebuild b/dev-cpp/gstreamermm/gstreamermm-1.4.3.ebuild
index 463e498f3800..4f8e13d9c739 100644
--- a/dev-cpp/gstreamermm/gstreamermm-1.4.3.ebuild
+++ b/dev-cpp/gstreamermm/gstreamermm-1.4.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -38,12 +38,16 @@ DEPEND="${RDEPEND}
# but that's okay, because the rest of dev-cpp/*mm stuff does the same
src_prepare() {
+ epatch "${FILESDIR}"/${PV}-fix-compile.patch
+
if ! use examples; then
# don't waste time building examples
sed -e 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
-i Makefile.am Makefile.in || die
fi
+ sed -e 's/ -Werror/ /' -i tests/Makefile.am tests/Makefile.in || die
+
gnome2_src_prepare
append-cxxflags -std=c++11 #568254 , fixed in master
}