summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-20 16:42:59 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-20 17:20:52 +0100
commited0cee72d7882fed428499bccefc412651763cf4 (patch)
tree57d57697d1675b0d629be5c33f9083d0f5c8ad40 /dev-cpp
parentmedia-sound/cmus: Remove old (diff)
downloadgentoo-ed0cee72d7882fed428499bccefc412651763cf4.tar.gz
gentoo-ed0cee72d7882fed428499bccefc412651763cf4.tar.bz2
gentoo-ed0cee72d7882fed428499bccefc412651763cf4.zip
dev-cpp/commoncpp2: Remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3564
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.8.1-r1.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.8.1-r1.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.8.1-r1.ebuild
deleted file mode 100644
index 6289e38f3007..000000000000
--- a/dev-cpp/commoncpp2/commoncpp2-1.8.1-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils autotools
-
-DESCRIPTION="C++ library offering portable support for system-related services"
-SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
-HOMEPAGE="https://www.gnu.org/software/commoncpp/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="debug doc examples ipv6 gnutls ssl static-libs"
-REQUIRED_USE="gnutls? ( ssl )"
-
-RDEPEND="ssl? ( gnutls? ( dev-libs/libgcrypt:0
- net-libs/gnutls )
- !gnutls? ( dev-libs/openssl:0 ) )
- sys-libs/zlib"
-DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
- ${RDEPEND}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}/1.8.1-configure_detect_netfilter.patch" \
- "${FILESDIR}/1.8.0-glibc212.patch" \
- "${FILESDIR}/1.8.1-autoconf-update.patch" \
- "${FILESDIR}/1.8.1-fix-buffer-overflow.patch" \
- "${FILESDIR}/1.8.1-parallel-build.patch" \
- "${FILESDIR}/1.8.1-libgcrypt.patch"
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- use doc || \
- sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
-
- local myconf
-
- if use gnutls; then
- myconf="--with-gnutls"
- else
- use ssl && myconf="--with-openssl"
- fi
-
- econf \
- $(use_enable debug) \
- $(use_with ipv6) \
- $(use_enable static-libs static) \
- ${myconf}
-}
-
-src_install () {
- default
- prune_libtool_files
-
- dodoc COPYING.addendum
-
- # Only install html docs
- # man and latex available, but seems a little wasteful
- use doc && dohtml doc/html/*
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- cd demo
- doins *.cpp *.h *.xml README
- fi
-}
-
-# Some of the tests hang forever
-#src_test() {
-# cd "${S}/tests"
-# emake || die "emake tests failed"
-# ./test.sh || die "tests failed"
-#}