summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2015-10-26 11:44:52 +0300
committerEray Aslan <eras@gentoo.org>2015-10-26 11:44:52 +0300
commit0a32d771562dcc35dc339a0b9ab386807f3585a8 (patch)
tree3590fa95379ec3df345d5bb577b236387b8d807e /dev-db/cdb
parentsci-libs/scipy: Backport fix for glibc-2.22 (diff)
downloadgentoo-0a32d771562dcc35dc339a0b9ab386807f3585a8.tar.gz
gentoo-0a32d771562dcc35dc339a0b9ab386807f3585a8.tar.bz2
gentoo-0a32d771562dcc35dc339a0b9ab386807f3585a8.zip
dev-db/cdb: compile with -fPIC
Gentoo-Bug: 563210 Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-db/cdb')
-rw-r--r--dev-db/cdb/cdb-0.75-r4.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-db/cdb/cdb-0.75-r4.ebuild b/dev-db/cdb/cdb-0.75-r4.ebuild
new file mode 100644
index 000000000000..5e335ed4b6ea
--- /dev/null
+++ b/dev-db/cdb/cdb-0.75-r4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DESCRIPTION="Fast, reliable, simple package for creating and reading constant databases"
+HOMEPAGE="http://cr.yp.to/cdb.html"
+SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4
+ !dev-db/tinycdb"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-errno.diff
+ epatch "${FILESDIR}"/${P}-stdint.diff
+
+ sed -i -e 's/head -1/head -n 1/g' Makefile \
+ || die "sed Makefile failed"
+}
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS} -fPIC" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "${EPREFIX}/usr" > conf-home
+}
+
+src_install() {
+ dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest \
+ || die "dobin failed"
+
+ # ok so ... first off, some automakes fail at finding
+ # cdb.a, so install that now
+ dolib *.a || die "dolib failed"
+
+ # then do this pretty little symlinking to solve the somewhat
+ # cosmetic library issue at hand
+ dosym cdb.a /usr/$(get_libdir)/libcdb.a || die "dosym failed"
+
+ # uint32.h needs installation too, otherwise compiles depending
+ # on it will fail
+ insinto /usr/include/cdb
+ doins cdb*.h buffer.h alloc.h uint32.h || die "doins failed"
+
+ dodoc CHANGES FILES README SYSDEPS TODO VERSION
+}