summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-15 23:12:15 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-15 23:12:39 +0300
commit93a165903aa5177a2d1446943fad99c60609bb5d (patch)
tree5bcb04c8a937f23d673171f6e72bc602201bcd5b /dev-db/etcd
parentdev-python/ipyparallel: Stabilize 8.6.1 ALLARCHES, #906476 (diff)
downloadgentoo-93a165903aa5177a2d1446943fad99c60609bb5d.tar.gz
gentoo-93a165903aa5177a2d1446943fad99c60609bb5d.tar.bz2
gentoo-93a165903aa5177a2d1446943fad99c60609bb5d.zip
dev-db/etcd: drop 3.3.24, 3.4.16
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-db/etcd')
-rw-r--r--dev-db/etcd/Manifest1
-rw-r--r--dev-db/etcd/etcd-3.3.24.ebuild86
-rw-r--r--dev-db/etcd/etcd-3.4.16.ebuild85
3 files changed, 0 insertions, 172 deletions
diff --git a/dev-db/etcd/Manifest b/dev-db/etcd/Manifest
index b9e3becc6222..7457405a4308 100644
--- a/dev-db/etcd/Manifest
+++ b/dev-db/etcd/Manifest
@@ -1,3 +1,2 @@
-DIST etcd-3.3.24.tar.gz 6518759 BLAKE2B bff713b5f754e6ed86f4265be7691f5cf6ad0bc1576ef15a4364b34dda827bef4390024d7a9bb032907dc8a95d8d3884e9f2ddf5a37b3b7e4ab476a13e61b8ac SHA512 a3825a1d6ec886a5f30317929bafc1f5b2657f374a4cb7a0348786a7c4f6b073197b2bdeb4d725e78cf5c99cead3e38dbf468ea023b3e7689bdce857466a72d3
DIST etcd-3.4.16-deps.tar.xz 36600528 BLAKE2B 3c8cbaef04b673962858cde9846a6a118eec785c0fc76b6e600b1686fd6e684f4b73af4aedb5886dfca51434e5738fb9bd0a39cdb81eda922e374c7668f0c0d0 SHA512 9119e09fc50bb916c3e436b9a4eea4b041184384865955f9b1a0f12e1334d9a143d49cc241ee51229e04fdfaedbbce24a66159107f52519b88a1e95cd64222df
DIST etcd-3.4.16.tar.gz 8853228 BLAKE2B 576d3f038f6e9e3eadaa9ba3935f8372271e9fd2cfb8ab193ce16ee57a55419daad4d8496f6ad27dcb833566e6eb077052422e1c86053d176a86b4305c8cc525 SHA512 3f413debe8bd723a00a3e39db05f6dbf414b7dc02f40f07d3037445c63b31c7bd8adaf77152ae01aa6aae3966f65393c5c8e352bbc2b86d01e5e2dd979c1c2e1
diff --git a/dev-db/etcd/etcd-3.3.24.ebuild b/dev-db/etcd/etcd-3.3.24.ebuild
deleted file mode 100644
index 42fa5b4fb66e..000000000000
--- a/dev-db/etcd/etcd-3.3.24.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module systemd tmpfiles
-GIT_COMMIT=bdd57848d
-MY_PV="${PV/_rc/-rc.}"
-
-DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
-HOMEPAGE="https://github.com/etcd-io/etcd"
-SRC_URI="https://github.com/etcd-io/etcd/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="doc +server"
-
-COMMON_DEPEND="server? (
- acct-group/etcd
- acct-user/etcd
- )"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}
- !dev-db/etcdctl"
-
-# Tests fail with this error:
-# fatal error: checkptr: unsafe pointer conversion
-RESTRICT="test"
-
-src_prepare() {
- export GO_BUILD_FLAGS="-mod=vendor -v -x"
- default
- sed -e "s|GIT_SHA=.*|GIT_SHA=${GIT_COMMIT}|"\
- -i "${S}"/build || die
- sed -e 's:\(for p in \)shellcheck :\1 :' \
- -e 's:^ gofmt \\$:\\:' \
- -e 's:^ govet \\$:\\:' \
- -e 's:^ govet_shadow \\$:\\:' \
- -i "${S}"/test || die
-
- sed -e "s|GO_BUILD_FLAGS=\"[^\"]*\"|GO_BUILD_FLAGS=\"${GO_BUILD_FLAGS}\"|" \
- -e "s|go test |go test ${GO_BUILD_FLAGS} |" \
- -i ./test || die
-
- mkdir -p vendor/github.com/coreos || die
- ln -s ../../.. vendor/github.com/coreos/etcd || die
-
- echo 'module go.etcd.io/etcd' > go.mod || die
-}
-
-src_compile() {
- ./build || die
-}
-
-src_test() {
- ./test || die
-}
-
-src_install() {
- dobin bin/etcdctl
- use doc && dodoc -r Documentation
- if use server; then
- insinto /etc/${PN}
- doins "${FILESDIR}/${PN}.conf"
- dobin bin/etcd
- dodoc README.md
- systemd_dounit "${FILESDIR}/${PN}.service"
- newtmpfiles "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- keepdir /var/lib/${PN}
- fowners ${PN}:${PN} /var/lib/${PN}
- fperms 0700 /var/lib/${PN}
- keepdir /var/log/${PN}
- fowners ${PN}:${PN} /var/log/${PN}
- fperms 755 /var/log/${PN}
- fi
-}
-
-pkg_postinst() {
- if use server; then
- tmpfiles_process ${PN}.conf
- fi
-}
diff --git a/dev-db/etcd/etcd-3.4.16.ebuild b/dev-db/etcd/etcd-3.4.16.ebuild
deleted file mode 100644
index 00f02ff1413f..000000000000
--- a/dev-db/etcd/etcd-3.4.16.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module systemd tmpfiles
-GIT_COMMIT=cf54fab42
-MY_PV="${PV/_rc/-rc.}"
-
-DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
-HOMEPAGE="https://github.com/etcd-io/etcd"
-SRC_URI="https://github.com/etcd-io/etcd/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-IUSE="doc +server"
-
-COMMON_DEPEND="server? (
- acct-group/etcd
- acct-user/etcd
- )"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}
- !dev-db/etcdctl"
-
-# Tests fail with this error:
-# fatal error: checkptr: unsafe pointer conversion
-RESTRICT+=" test "
-
-src_prepare() {
- export GO_BUILD_FLAGS="-v -x"
- default
- sed -e "s|GIT_SHA=.*|GIT_SHA=${GIT_COMMIT}|"\
- -i "${S}"/build || die
- sed -e 's:\(for p in \)shellcheck :\1 :' \
- -e 's:^ gofmt \\$:\\:' \
- -e 's:^ govet \\$:\\:' \
- -e 's:^ govet_shadow \\$:\\:' \
- -i "${S}"/test || die
-
- sed -e "s|GO_BUILD_FLAGS=\"[^\"]*\"|GO_BUILD_FLAGS=\"${GO_BUILD_FLAGS}\"|" \
- -e "s|go test |go test ${GO_BUILD_FLAGS} |" \
- -i ./test || die
-
-# mkdir -p vendor/github.com/coreos || die
-# ln -s ../../.. vendor/github.com/coreos/etcd || die
-}
-
-src_compile() {
- ./build || die
-}
-
-src_test() {
- ./test || die
-}
-
-src_install() {
- dobin bin/etcdctl
- use doc && dodoc -r Documentation
- if use server; then
- insinto /etc/${PN}
- doins "${FILESDIR}/${PN}.conf"
- dobin bin/etcd
- dodoc README.md
- systemd_dounit "${FILESDIR}/${PN}.service"
- newtmpfiles "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- keepdir /var/lib/${PN}
- fowners ${PN}:${PN} /var/lib/${PN}
- fperms 0700 /var/lib/${PN}
- keepdir /var/log/${PN}
- fowners ${PN}:${PN} /var/log/${PN}
- fperms 755 /var/log/${PN}
- fi
-}
-
-pkg_postinst() {
- if use server; then
- tmpfiles_process ${PN}.conf
- fi
-}