summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-03-16 15:33:40 -0700
committerZac Medico <zmedico@gentoo.org>2019-03-16 15:37:53 -0700
commitd0bfc9000af5a2b88c070c772bd0dca16a50279c (patch)
tree1bc3f8f9fbcff8afb35564c8650ceba4415b1e6e /dev-db/etcd
parentsys-cluster/zookeepercli: filter GOCACHE vars (bug 678960) (diff)
downloadgentoo-d0bfc9000af5a2b88c070c772bd0dca16a50279c.tar.gz
gentoo-d0bfc9000af5a2b88c070c772bd0dca16a50279c.tar.bz2
gentoo-d0bfc9000af5a2b88c070c772bd0dca16a50279c.zip
dev-db/etcd: remove old versionS
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-db/etcd')
-rw-r--r--dev-db/etcd/Manifest2
-rw-r--r--dev-db/etcd/etcd-3.3.10.ebuild77
-rw-r--r--dev-db/etcd/etcd-3.3.11.ebuild77
3 files changed, 0 insertions, 156 deletions
diff --git a/dev-db/etcd/Manifest b/dev-db/etcd/Manifest
index 9e0ae15fe938..e355c67cde28 100644
--- a/dev-db/etcd/Manifest
+++ b/dev-db/etcd/Manifest
@@ -1,3 +1 @@
-DIST etcd-3.3.10.tar.gz 3526904 BLAKE2B 8266212707f8fb280d55deba8dffb44e4d48b906c56034b174848fe6f237d5efba8c15ebea076d799db7f3ec560e2d188fdcc8fe26334ae1cbef0384fe8cf847 SHA512 848e241e816312307f74520b99aeabf7def6862093897035ace16cb230817d8e2681d7d2f1c1ac220d7c2b4c7c0a1262bbe3e4db927524f785de888566d2097c
-DIST etcd-3.3.11.tar.gz 3526863 BLAKE2B 5daf511e0d1d064a141a29de456aca0a837567052e3c742afc535405e04c90c70dd347b90960df2decadc53a38ceaf7acfad9346677cb17f892ece437cdf10e8 SHA512 4274c4988b6e7fe61dbcc88c88ed6647debd7a67c448b9101c77bebeef6400e65b9e2cc930f635c3f59105554411e1ac606c6a146ad6927a01d2e921b1a92949
DIST etcd-3.3.12.tar.gz 3527586 BLAKE2B fdc4e3e9522c032d951045d4eda7f36743d4fbbb4ea8673bbe00bb38931cd7442910b0b54eeb6df0957439332df498389f3568ba7e8bdecfbd873fecfb3df86f SHA512 63ba6130bd93471260b8d90760455bccef2755e672a9df39224491188c69e4e3e8c1157cfb639c4002fb8a6d16950f7ff448a83e0acbc389162b742f3df6234f
diff --git a/dev-db/etcd/etcd-3.3.10.ebuild b/dev-db/etcd/etcd-3.3.10.ebuild
deleted file mode 100644
index b1e380183334..000000000000
--- a/dev-db/etcd/etcd-3.3.10.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit user systemd golang-vcs-snapshot
-
-KEYWORDS="amd64"
-EGO_PN="github.com/coreos/etcd"
-GIT_COMMIT="27fc7e2"
-MY_PV="${PV/_rc/-rc.}"
-DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
-HOMEPAGE="https://github.com/coreos/etcd"
-SRC_URI="https://${EGO_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="doc +server"
-DEPEND=">=dev-lang/go-1.9:="
-RDEPEND="!dev-db/etcdctl"
-
-src_prepare() {
- default
- sed -e "s|GIT_SHA=.*|GIT_SHA=${GIT_COMMIT}|"\
- -i "${S}"/src/${EGO_PN}/build || die
- sed -e 's:\(for p in \)shellcheck :\1 :' \
- -e 's:^ gofmt \\$:\\:' \
- -e 's:^ govet \\$:\\:' \
- -i "${S}"/src/${EGO_PN}/test || die
- # missing ... in args forwarded to print-like function
- sed -e 's:l\.Logger\.Panic(v):l.Logger.Panic(v...):' \
- -i "${S}"/src/${EGO_PN}/raft/logger.go || die
-}
-
-pkg_setup() {
- if use server; then
- enewgroup ${PN}
- enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
- fi
-}
-
-src_compile() {
- export GOPATH=${S}
- pushd src/${EGO_PN} || die
- GO_BUILD_FLAGS=-v ./build || die
- popd || die
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin bin/etcdctl
- use doc && dodoc -r Documentation
- if use server; then
- insinto /etc/${PN}
- doins "${FILESDIR}/${PN}.conf"
- dobin bin/etcd
- dodoc README.md
- systemd_dounit "${FILESDIR}/${PN}.service"
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- keepdir /var/lib/${PN}
- fowners ${PN}:${PN} /var/lib/${PN}
- fperms 0700 /var/lib/${PN}
- keepdir /var/log/${PN}
- fowners ${PN}:${PN} /var/log/${PN}
- fperms 755 /var/log/${PN}
- fi
- popd || die
-}
-
-src_test() {
- pushd src/${EGO_PN} || die
- ./test || die
- popd || die
-}
diff --git a/dev-db/etcd/etcd-3.3.11.ebuild b/dev-db/etcd/etcd-3.3.11.ebuild
deleted file mode 100644
index 40c9067fb1d4..000000000000
--- a/dev-db/etcd/etcd-3.3.11.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit user systemd golang-vcs-snapshot
-
-KEYWORDS="~amd64"
-EGO_PN="github.com/etcd-io/etcd"
-GIT_COMMIT="2cf9e51"
-MY_PV="${PV/_rc/-rc.}"
-DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
-HOMEPAGE="https://github.com/etcd-io/etcd"
-SRC_URI="https://${EGO_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="doc +server"
-DEPEND=">=dev-lang/go-1.10:="
-RDEPEND="!dev-db/etcdctl"
-
-src_prepare() {
- default
- sed -e "s|GIT_SHA=.*|GIT_SHA=${GIT_COMMIT}|"\
- -i "${S}"/src/${EGO_PN}/build || die
- sed -e 's:\(for p in \)shellcheck :\1 :' \
- -e 's:^ gofmt \\$:\\:' \
- -e 's:^ govet \\$:\\:' \
- -i "${S}"/src/${EGO_PN}/test || die
- # missing ... in args forwarded to print-like function
- sed -e 's:l\.Logger\.Panic(v):l.Logger.Panic(v...):' \
- -i "${S}"/src/${EGO_PN}/raft/logger.go || die
-}
-
-pkg_setup() {
- if use server; then
- enewgroup ${PN}
- enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
- fi
-}
-
-src_compile() {
- export GOPATH=${S}
- pushd src/${EGO_PN} || die
- GO_BUILD_FLAGS=-v ./build || die
- popd || die
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin bin/etcdctl
- use doc && dodoc -r Documentation
- if use server; then
- insinto /etc/${PN}
- doins "${FILESDIR}/${PN}.conf"
- dobin bin/etcd
- dodoc README.md
- systemd_dounit "${FILESDIR}/${PN}.service"
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- keepdir /var/lib/${PN}
- fowners ${PN}:${PN} /var/lib/${PN}
- fperms 0700 /var/lib/${PN}
- keepdir /var/log/${PN}
- fowners ${PN}:${PN} /var/log/${PN}
- fperms 755 /var/log/${PN}
- fi
- popd || die
-}
-
-src_test() {
- pushd src/${EGO_PN} || die
- ./test || die
- popd || die
-}