summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-09-13 15:29:41 +0200
committerFabian Groffen <grobian@gentoo.org>2020-09-13 15:29:57 +0200
commit8a9e9a2a6cdda4d42822599fef759d83672b1a10 (patch)
treecb0af7d59f6d842afbcf658b353cf9aaa56880e9 /dev-db/gqlplus
parentdev-util/spirv-llvm-translator: bump to 10.0.0_p20200909 (diff)
downloadgentoo-8a9e9a2a6cdda4d42822599fef759d83672b1a10.tar.gz
gentoo-8a9e9a2a6cdda4d42822599fef759d83672b1a10.tar.bz2
gentoo-8a9e9a2a6cdda4d42822599fef759d83672b1a10.zip
dev-db/gqlplus-1.16: fix configure with ncurses[tinfo], bug #742242
Closes: https://bugs.gentoo.org/742242 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-db/gqlplus')
-rw-r--r--dev-db/gqlplus/files/gqlplus-1.16-ncurses-tinfo.patch19
-rw-r--r--dev-db/gqlplus/gqlplus-1.16.ebuild11
2 files changed, 27 insertions, 3 deletions
diff --git a/dev-db/gqlplus/files/gqlplus-1.16-ncurses-tinfo.patch b/dev-db/gqlplus/files/gqlplus-1.16-ncurses-tinfo.patch
new file mode 100644
index 000000000000..e39085e0daba
--- /dev/null
+++ b/dev-db/gqlplus/files/gqlplus-1.16-ncurses-tinfo.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,14 +4,6 @@
+ AC_PROG_CC
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+-AC_CHECK_LIB(ncurses, tgetnum,,
+-[
+- echo "The required library ncurses not found - aborting."
+- exit
+-],)
+-AC_CHECK_LIB(readline, tputs,,
+-[
+- echo "The required library readline not found - aborting."
+- exit
+-],)
++AC_SEARCH_LIBS([tgetnum], [ncurses tinfo], , AC_MSG_ERROR([need ncurses]), [])
++AC_CHECK_LIB(readline, tputs, , AC_MSG_ERROR([need readline]), [])
+ AC_OUTPUT(Makefile)
diff --git a/dev-db/gqlplus/gqlplus-1.16.ebuild b/dev-db/gqlplus/gqlplus-1.16.ebuild
index a3aa8f209869..b21f38c84694 100644
--- a/dev-db/gqlplus/gqlplus-1.16.ebuild
+++ b/dev-db/gqlplus/gqlplus-1.16.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit autotools
DESCRIPTION="a front-end for Oracle program sqlplus with command-line editing"
-HOMEPAGE="https://sourceforge.net/projects/gqlplus/"
+HOMEPAGE="https://gitlab.com/jessp011/gqlplus"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
@@ -17,12 +17,17 @@ IUSE=""
DEPEND="sys-libs/readline:*"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-ncurses-tinfo.patch )
+
src_prepare() {
+ default
+
# don't use packaged readline and old version containing it
rm -Rf readline gqlplus-1.15
# maintainer can't seem to get versioning right
sed -i '/^#define VERSION/s/"[^"]\+"/"'"${PV}"'"/' gqlplus.c || die
sed -i '/^AC_INIT/s/\[[1-9.]\+\]/['"${PV}"']/' configure.ac || die
+
eautoreconf
}